This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1029722 - Use reap action as default for running deleted instances from nova-dist.conf
Use reap action as default for running deleted instances from nova-dist.conf
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: rc
: 4.0
Assigned To: Xavier Queralt
Pavel Sedlák
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 20:53 EST by Stephen Gordon
Modified: 2016-04-26 10:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-5.el6ost
Doc Type: Enhancement
Doc Text:
The Compute service periodically checks for instances that have been deleted in the database but remain running on a compute node. The action to take when such instances are identified is determined by the value of the "running_deleted_instance_action" configuration key in the OpenStack Compute (/etc/nova/nova.conf) file. The default value of the "running_deleted_instance_action" configuration key has been changed to "reap". In previous releases the default value of this configuration key was "log". As a result of this change when running instances are discovered that have previously been deleted from the database they are now stopped and removed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:35:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 50188 None None None Never

  None (edit)
Description Stephen Gordon 2013-11-12 20:53:20 EST
Description of problem:

Request backport from upstream master:

"""
Update default for running_deleted_instance_action

Update the default value of running_deleted_instance_action to 'reap'
from 'log'. Consensus seems to be that this is what most people expect.

DocImpact

http://lists.openstack.org/pipermail/openstack-dev/2013-October/016153.html
"""

Version-Release number of selected component (if applicable):

4.0

Additional info:

Updated default matches customer expectations.
Comment 1 Russell Bryant 2013-11-13 08:50:17 EST
We changed this to be the default upstream for the Icehouse release.  It's not the kind of thing I would want to change within a release.  Since RHOS 4 has not been released yet, I would be OK with changing the default to 'reap'.
Comment 4 Xavier Queralt 2013-11-29 01:41:06 EST
The key running_deleted_instance_action is set to "reap" by default in nova-dist.conf:

[root@rhos1 ~]# rpm -qa openstack-nova-common
openstack-nova-common-2013.2-5.el6ost.noarch

[root@rhos1 ~]# grep running_deleted_instance_action /usr/share/nova/nova-dist.conf 
running_deleted_instance_action=reap
Comment 5 Pavel Sedlák 2013-12-04 12:24:07 EST
Verified, in new version option is there in nova-dist.conf:

# rpm -qa openstack-nova-common
> openstack-nova-common-2013.2-5.el6ost.noarch

# grep deleted_inst /etc/nova/*
> /etc/nova/nova.conf:#running_deleted_instance_action=log
> /etc/nova/nova.conf:#running_deleted_instance_poll_interval=1800
> /etc/nova/nova.conf:#running_deleted_instance_timeout=0

# grep deleted_inst /usr/share/nova/nova-dist.conf 
> running_deleted_instance_action=reap


in older version there was no entry like that at all:

# rpm -qa openstack-nova-common
> openstack-nova-common-2013.2-0.24.rc1.el6ost.noarch

# grep deleted_inst /etc/nova/*
> /etc/nova/nova.conf:#running_deleted_instance_action=log
> /etc/nova/nova.conf:#running_deleted_instance_poll_interval=1800
> /etc/nova/nova.conf:#running_deleted_instance_timeout=0

# grep deleted_inst /usr/share/nova/nova-dist.conf
>  

# cat /usr/share/nova/nova-dist.conf 
> [DEFAULT]
> log_dir = /var/log/nova
> state_path = /var/lib/nova
> lock_path = /var/lib/nova/tmp
> dhcpbridge = /usr/bin/nova-dhcpbridge
> dhcpbridge_flagfile = /usr/share/nova/nova-dist.conf
> dhcpbridge_flagfile = /etc/nova/nova.conf
> force_dhcp_release = True
> injected_network_template = /usr/share/nova/interfaces.template
> libvirt_nonblocking = True
> libvirt_inject_partition = -1
> network_manager = nova.network.manager.FlatDHCPManager
> compute_driver = libvirt.LibvirtDriver
> firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
> rpc_backend = nova.openstack.common.rpc.impl_qpid
> rootwrap_config = /etc/nova/rootwrap.conf
> 
> [database]
> connection = mysql://nova:nova@localhost/nova
> max_retries = -1
>
> [keystone_authtoken]
> admin_tenant_name = %SERVICE_TENANT_NAME%
> admin_user = %SERVICE_USER%
> admin_password = %SERVICE_PASSWORD%
> auth_host = 127.0.0.1
> auth_port = 35357
> auth_protocol = http
> signing_dir = /tmp/keystone-signing-nova
> # Workaround for https://bugs.launchpad.net/nova/+bug/1154809
> auth_version = v2.0
Comment 7 errata-xmlrpc 2013-12-19 19:35:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.