Bug 1029723 - RFE - Support for Markdown input files
RFE - Support for Markdown input files
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 21:15 EST by Misty Stanley-Jones
Modified: 2017-01-09 05:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-09 05:19:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misty Stanley-Jones 2013-11-12 21:15:48 EST
My understanding is that Publican's new support of Docbook 5 means that Publican has the capacity to support other input formats in a pluggable way. I'd like to put Asciidoc, or its extension Asciidoctor, forward as a potential target for support. Asciidoc is a lightweight markup language, a superset of Markdown, with additional features. It is similar to Restructured Text. Asciidoc and Markdown have both become very popular with developers who use Github, as Github has the ability to render the source files as HTML in the browser interface. Asciidoctor is being spearheaded by Red Hat engineers. Red Hat GSS use Markdown a great deal. O'Reilly and others are now using Markdown and Asciidoc, as well. I believe all four structured text syntaxes have more similarities with each other than differences. Because of the similarities, I've included them all in this RFE. Feel free to divide it out, though.

AsciiDoc: http://www.methods.co.nz/asciidoc/
AsciiDoctor: http://asciidoctor.org/
MarkDown: http://daringfireball.net/projects/markdown/
RestructuredText: http://docutils.sourceforge.net/rst.html
Comment 2 Jeff Fearn 2013-11-24 19:30:52 EST
One bug, one feature. When you open one bug with lots of features it means I get to take my pick of which bits to do as part of the bug. It's entirely unfair but that's how we devs roll :D

For this bug I will do the subset of these that are covered by

http://search.cpan.org/~dwheeler/Text-Markup-0.18/
and
https://alioth.debian.org/scm/viewvc.php/trunk/?root=po4a

Future bugs will then be addressed at adding missing formats to those two upstream projects.
Comment 3 Ruediger Landmann 2014-02-25 00:32:05 EST
[15:32] <rudi> On another subject, which text input format would you like added to Publican first?

[15:32] <misty> Asciidoc but I'll take Markdown as Asciidoc is a superset of it

Markdown it is!
Comment 4 Jeff Fearn 2014-03-16 21:04:27 EDT
Bumping to 4.2 due to extra work caused by PDFs.
Comment 6 Jeff Fearn 2017-01-09 05:19:20 EST
This is a lot of work for questionable value given there are a lot of tools that convert markdown/asciidoc/etc to docbook.

IMO we'd be better off spending time making piping output from those tools work better if they are having any problems doing so.

Note You need to log in before you can comment on or make changes to this bug.