Bug 1029733 - Remote server error with subscription-manager clean.
Remote server error with subscription-manager clean.
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam14-tracker
  Show dependency treegraph
 
Reported: 2013-11-12 22:26 EST by qianzhan
Modified: 2014-06-10 08:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-10 08:13:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'rhsm.log' (16.98 KB, text/x-log)
2013-11-12 22:27 EST, qianzhan
no flags Details
‘katello-debug-20131112221225.tar.gz’ (185.35 KB, application/x-gzip)
2013-11-12 22:28 EST, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-11-12 22:26:32 EST
Description of problem:
Remote server error with subscription-manager clean.

Version-Release number of selected component (if applicable):
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-11.el6sat.noarch
katello-cli-common-1.4.3-11.el6sat.noarch
katello-common-1.4.3.23-1.el6sam_splice.noarch
katello-configure-1.4.4-5.el6sam.noarch
katello-glue-candlepin-1.4.3.23-1.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3.23-1.el6sam_splice.noarch
katello-headpin-1.4.3.23-1.el6sam_splice.noarch
katello-headpin-all-1.4.3.23-1.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
ruby193-rubygem-katello-redhat-access-engine-0.0.1-1.el6sam.noarch
candlepin-0.8.26-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.26-1.el6sam.noarch
candlepin-tomcat6-0.8.26-1.el6sam.noarch
thumbslug-0.0.34-1.el6sam.noarch
thumbslug-selinux-0.0.34-1.el6sam.noarch
subscription-manager: 1.10.6-1.el7
python-rhsm: 1.10.6-1.el7

How reproducible:
always

Steps to Reproduce:
1. Check the system times on RHEL7.0 client and SAM server.
(1) On SAM server:
[root@samserv ~]# date
Tue Nov 12 21:58:06 EST 2013

(2) On client:
[root@localhost ~]# date
Tue Nov 12 22:02:40 EST 2013

2. Register to SAM:
[root@localhost ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: c39e49ba-4954-4bda-98af-52c19f82acee 

3. Clean local data:
[root@localhost ~]# subscription-manager clean
All local data removed
Remote server error. Please check the connection details, or see /var/log/rhsm/rhsm.log for more information.

Actual results:
As step 3.

Expected results:
No error happens when clean local data.

Additional info:
1. rhsm.log is attached as 'rhsm.log'.
2. katello-debug info is attached as 'katello-debug-20131112221225.tar.gz'.
3. I tested on stage candlepin, and this issue does not exist.
[root@localhost ~]# vim /etc/rhsm/rhsm.conf 
[root@localhost ~]# subscription-manager register
Username: stage_test_12
Password: 
The system has been registered with ID: 47e80e1e-4c56-4850-9f4c-38b31f761206 
[root@localhost ~]# subscription-manager clean
All local data removed
Comment 1 qianzhan 2013-11-12 22:27:04 EST
Created attachment 823241 [details]
'rhsm.log'
Comment 2 qianzhan 2013-11-12 22:28:33 EST
Created attachment 823242 [details]
‘katello-debug-20131112221225.tar.gz’
Comment 3 Carter Kozak 2013-11-25 09:12:11 EST
This should be in the latest errata, can you please re-test and confirm?

commit 9d72108cb76ae63339f91732f4cb60df473bff33
Author: ckozak <ckozak@redhat.com>
Date:   Mon Nov 11 09:54:45 2013 -0500

    Remove unnecessary network calls after clean command
    
    The cached identity value was not properly updated when the
    clean command was run.  It is being manually reloaded now in
    order to stop the compliance manager (CertSorter) from attempting
    any network activity.
Comment 4 qianzhan 2013-12-20 02:51:27 EST
Verifying version:
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-11.el6sat.noarch
katello-cli-common-1.4.3-11.el6sat.noarch
katello-common-1.4.3.23-1.el6sam_splice.noarch
katello-configure-1.4.4-5.el6sam.noarch
katello-glue-candlepin-1.4.3.23-1.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3.23-1.el6sam_splice.noarch
katello-headpin-1.4.3.23-1.el6sam_splice.noarch
katello-headpin-all-1.4.3.23-1.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
ruby193-rubygem-katello-redhat-access-engine-0.0.1-1.el6sam.noarch
candlepin-0.8.26-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.26-1.el6sam.noarch
candlepin-tomcat6-0.8.26-1.el6sam.noarch
thumbslug-0.0.34-1.el6sam.noarch
thumbslug-selinux-0.0.34-1.el6sam.noarch

subscription-manager: 1.10.8-1.el7
python-rhsm: 1.10.8-1.el7

Test Steps:
1. Register to SAM:
[root@dhcp-65-40 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: 42a641c2-1328-4522-bc7a-3c615d6d228b 

2. Clean local data:
[root@dhcp-65-40 ~]# subscription-manager clean
All local data removed
[root@dhcp-65-40 ~]# 

As above steps, the bug has been fixed, please move it status to 'ON_QA' so that I can set the status as 'VERIFIED'.
Comment 5 qianzhan 2014-02-08 02:41:33 EST
Verifying version:
vevifying components of SAM are the same with comments 4.
subscription-manager: 1.10.13-1.el7
python-rhsm: 1.10.12-1.el7

Test Steps:
1. Register to SAM:
[root@dhcp-65-117 ~]# subscription-manager register
Username: admin
Password: 
The system has been registered with ID: bd749a08-6a06-4b5f-b34a-05864cd672fc 


2. Clean local data:
[root@dhcp-65-117 ~]# subscription-manager clean
All local data removed
[root@dhcp-65-117 ~]# 

As above steps, the bug has been fixed. Moving the status to 'VERIFIED'
Comment 8 errata-xmlrpc 2014-06-10 08:13:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0677.html

Note You need to log in before you can comment on or make changes to this bug.