Bug 1029762 - Deployment of webservice with nonexisting or invalid endpoint config does not fail
Deployment of webservice with nonexisting or invalid endpoint config does not...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
TBD EAP 6
Unspecified Unspecified
medium Severity medium
: DR0
: EAP 6.3.0
Assigned To: Rebecca Searls
Rostislav Svoboda
Russell Dickenson
:
Depends On: 1061340
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 02:13 EST by Petr Sakař
Modified: 2014-06-28 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:38:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff of code changes (2.04 KB, patch)
2013-12-10 16:27 EST, Rebecca Searls
no flags Details | Diff

  None (edit)
Description Petr Sakař 2013-11-13 02:13:22 EST
Description of problem:
Web Service requires end point config, which is not configured on server. Deployment containing such service should fail if the config is not defined

@org.apache.cxf.annotations.Logging(pretty=true)
@EndpointConfig(configName = "sts-config")
@javax.jws.WebService
public class TestEndpointImpl
{
  public String hello(String name)
  {
    return "Hello, " + name + "!";
  }
}

Version-Release number of selected component (if applicable):
6.2.0.CR1

How reproducible:
Always

Steps to Reproduce:
see https://bugzilla.redhat.com/show_bug.cgi?id=1021049#c13 and following comment from Alessio.


Actual results:

Deployment succeds

Expected results:

Deployment fails
Comment 1 Alessio Soldano 2013-11-13 11:25:40 EST
I'm fine with this, upstream jira: https://issues.jboss.org/browse/JBWS-3732
This is not going to be fixed in EAP 6.2, though. Will need to move to 6.3.
Comment 2 Petr Sakař 2013-11-29 07:32:37 EST
Additional scenario:

Endpoint config is defined but handler class is wrong - I would say it should result in deployment failure as well
Comment 4 Rebecca Searls 2013-12-10 16:27:20 EST
Created attachment 834940 [details]
diff of code changes
Comment 6 Kabir Khan 2014-04-04 10:53:51 EDT
Setting to ON_QA since upgrade should fix this
Comment 7 Petr Sakař 2014-04-08 05:52:03 EDT
Verified for EAP-6.3.0.ER1

Note You need to log in before you can comment on or make changes to this bug.