Bug 1029775 - Horizon requires python-pbr at runtime
Horizon requires python-pbr at runtime
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity urgent
: beta
: 4.0
Assigned To: Matthias Runge
Nir Magnezi
: Triaged
: 1039368 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 02:55 EST by Matthias Runge
Modified: 2013-12-19 19:35 EST (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-4.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:35:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2013-11-13 02:55:14 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Matthias Runge 2013-11-13 02:57:26 EST
When installing horizon on a separate host (not doing all-in-one installs), you'll get the "Something went wrong page". After installing python-pbr and restart the webserver as well, everything is fine.
Comment 4 Matthias Runge 2013-11-14 08:12:13 EST
This will require to change add to the spec accordingly:

sed -i '/setuptools_git/d' setup.py
sed -i s/REDHATNOVAVERSION/%{version}/ nova/version.py
sed -i s/REDHATNOVARELEASE/%{release}/ nova/version.py

# Remove the requirements file so that pbr hooks don't add it 
# to distutils requiers_dist config
rm -rf {test-,}requirements.txt tools/{pip,test}-requires
Comment 6 Nir Magnezi 2013-11-20 07:58:35 EST
Verified: python-django-horizon-2013.2-5.el6ost.noarch

Verification Steps:
===================
1. Installed openstack via packstack with a dedicated host to populate horizon (Comment #1).
2. Verified that /usr/lib/python2.6/site-packages/horizon/version.py does not contain import pbr.version
3. Browsed Horizon via http://<IP_ADDRESS>/dashboard. tested OK.
Comment 7 Martin Magr 2013-12-09 08:25:56 EST
*** Bug 1039368 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2013-12-19 19:35:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.