Bug 1029794 - Cannot install Fedora 20 on already encrypted LVM
Cannot install Fedora 20 on already encrypted LVM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 03:50 EST by Johan Vervloet
Modified: 2014-01-04 11:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 10:47:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
From attempted anaconda install involving an encrypted partition. (28.00 KB, application/octet-stream)
2014-01-04 11:40 EST, Stephen P. Schaefer
no flags Details
Log from attempted kickstart install involving an encrypted partition. (110.14 KB, text/plain)
2014-01-04 11:42 EST, Stephen P. Schaefer
no flags Details

  None (edit)
Description Johan Vervloet 2013-11-13 03:50:49 EST
Description of problem:

My hard disk is already set up with encrypted LVM. The volumes I want to install Fedora 20 on are already created as well.

I didn't manage to install Fedora. After configuring the paritios, I get an error message: Error checking storage configuration.


Version-Release number of selected component (if applicable):

The installer of the live system

How reproducible:


Steps to Reproduce:
1. Start the installer
2. Choose the hard disk to install
3. Choose manual partitioning
4. Click on the encrypted partitions. Enter the password. They got decrypted.
5. The physical volumes are detected
6. I selected the root partition, checked the 'format' box, and set the mount point to /. I took a swap partition, and checked 'format' as well. For the home partition, I set the mount point to /home, and I did not check 'format'.
7. I Clicked done.

Actual results:

An error message: Error checking storage configuration

Expected results:

The system should start to install.

Additional info:
Comment 1 Johan Vervloet 2013-11-13 04:13:27 EST
I forgot to mention that I also configured a boot partition, which is not LVM.
Comment 2 Johan Vervloet 2013-11-13 04:21:47 EST
I tried to install with the NetInst ISO today, and I didn't encounter the problem. So maybe I did something wrong yesterday.
Comment 3 David Shea 2013-11-13 10:47:03 EST
Glad to hear it's working for you. If you encounter the problem again, reopen this bug and attach the storage.log and storage.state files from /tmp.
Comment 4 Stephen P. Schaefer 2014-01-04 11:40:15 EST
Created attachment 845400 [details]
From attempted anaconda install involving an encrypted partition.
Comment 5 Stephen P. Schaefer 2014-01-04 11:41:16 EST
I'm having similar trouble, except I'm trying to use kickstart.  Anaconda did nothing with the encrypted partiion (no password prompt), but I worked around that by putting this line in the %pre section:

cryptsetup luksOpen /dev/vga2 pv.253002

Although the volume group is subsequently configured, anaconda nonetheless does not recognize it; dmsetup ls --tree shows

live-base (253:1)
 `- (7:1)
vg_thyrsuslaptop-lv_home (253:5)
 `-pv.253002 (253:2)
    `- (252:2)
vg_thyrsuslaptop-lv_swap (253:3)
 `-pv.253002 (253:2)
    `- (252:2)
vg_thyrsuslaptop-lv_root (253:4)
 `-pv.253002 (253:2)
    `- (252:2)
live-rw (253:0)
 |- (7:2)
 `- (7:1)

...yet I'm prompted:
===
storage configuration failed: the following problem occured on line 46 of the kickstart file:

No volume group exists with the name "vg_thyrsuslaptop".  Specify volume groups before logical volumes.
===
I've tried both commented an uncommented line 45

# volgroup vg_thyrsuslaptop --pesize=32768 --noformat

and in both cases dmsetup reports successful creation of logical volumes as above, but with the line uncommented the only difference is that the remark "Specify volume groups before logical volumes." is omitted.  I'm attaching storage.log and storage.state from the latest attempt

This is a regression from F17, where it was sufficient to specify

part  --encrypted --onpart=${disk}2 --noformat pv.253002

and after prompting for the partition passphrase, everything worked.  WIthout the workaround in %pre, F20 never prompts for a password for /dev/vga2.  (I'm working on a virtual machine to resolve problems before applying the reinstall to my actual laptop).
Comment 6 Stephen P. Schaefer 2014-01-04 11:42:41 EST
Created attachment 845412 [details]
Log from attempted kickstart install involving an encrypted partition.

Note You need to log in before you can comment on or make changes to this bug.