Bug 1029822 - mouse selection and pagination numbering issue for ibus-typing-booster
Summary: mouse selection and pagination numbering issue for ibus-typing-booster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 20
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-13 10:08 UTC by Bhushan Barve
Modified: 2013-12-14 03:32 UTC (History)
6 users (show)

Fixed In Version: ibus-typing-booster-1.2.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 07:12:03 UTC


Attachments (Terms of Use)
ibus-typing-booster incorrect numbering (73.42 KB, image/png)
2013-11-13 10:10 UTC, Bhushan Barve
no flags Details
0001-Commit-candidate-clicked-on-with-the-mouse.patch (1.16 KB, patch)
2013-11-14 12:32 UTC, Mike FABIAN
no flags Details | Diff

Description Bhushan Barve 2013-11-13 10:08:13 UTC
Description of problem:
There are two issues in this:
-mouse selection from the candidate window in ibus-typing-booster.
-numbering does not get changed after going to next candidate window. 


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1.install ibus-typing-booster and enable it.
2.open gedit.
3.enter a word and press tab key
4.candidate selection window will appear giving suggestions.
5.try to select a word using mouse.
6.go to next window and observe the numbering.

Actual results:
mouse selection does not work.
numbering per page does not change.

Expected results:
mouse selection should change.
numbering should change per page.

Additional info:

Comment 1 Bhushan Barve 2013-11-13 10:10:59 UTC
Created attachment 823322 [details]
ibus-typing-booster incorrect numbering

Comment 2 Mike FABIAN 2013-11-14 12:32:25 UTC
Created attachment 823923 [details]
0001-Commit-candidate-clicked-on-with-the-mouse.patch

Fix to commit candidates clicked on with the mouse.

Comment 3 Fedora Update System 2013-11-14 13:23:37 UTC
ibus-typing-booster-1.2.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.6-1.fc20

Comment 4 Fedora Update System 2013-11-14 13:24:42 UTC
ibus-typing-booster-1.2.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.6-1.fc19

Comment 5 Fedora Update System 2013-11-14 13:25:27 UTC
ibus-typing-booster-1.2.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.6-1.fc18

Comment 6 Mike FABIAN 2013-11-14 14:20:45 UTC
The update makes  it possible to click on candidates with the mouse
to commit them.

This update does *not* change the numbers in front of the candidates.
Because the numbers in front of the candidates look correct to me.

The numbers show, which number key can be pressed to select and commit that candidate.

I.e. if the candidate list looks like 

(13/20)
1 meant
2 meany
3 meaty
4 mecca
5 medal
6 media

as in your screen shot, then typing '5' will select and commit "medal".

Comment 7 Fedora Update System 2013-11-14 19:18:11 UTC
Package ibus-typing-booster-1.2.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-typing-booster-1.2.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21346/ibus-typing-booster-1.2.6-1.fc20
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-11-20 14:49:49 UTC
ibus-typing-booster-1.2.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.7-1.fc18

Comment 9 Fedora Update System 2013-11-20 14:51:41 UTC
ibus-typing-booster-1.2.7-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.7-1.fc19

Comment 10 Fedora Update System 2013-11-20 14:53:13 UTC
ibus-typing-booster-1.2.7-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ibus-typing-booster-1.2.7-1.fc20

Comment 11 Bhushan Barve 2013-11-21 07:12:03 UTC
Verified with the ibus-typing-booster-1.2.7-1.fc20 package as mentioned in the above comments.
mouse selection for ibus-typing-booster is working fine now. Ok with the explanation given for numbering issue. 
Hence marking it as closed.

Comment 12 Fedora Update System 2013-12-11 02:02:07 UTC
ibus-typing-booster-1.2.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-12-11 02:03:08 UTC
ibus-typing-booster-1.2.7-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-12-14 03:32:27 UTC
ibus-typing-booster-1.2.7-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.