Bug 1029838 - Stopping sssd service doesn't kill sssd daemon started from cmdline
Stopping sssd service doesn't kill sssd daemon started from cmdline
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 05:39 EST by Kaushik Banerjee
Modified: 2013-11-14 09:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 09:05:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushik Banerjee 2013-11-13 05:39:33 EST
Description of problem:
Stopping sssd service doesn't kill sssd daemon started from cmdline

Version-Release number of selected component (if applicable):
1.11.2-1.el7

How reproducible:
Always

Steps to Reproduce:
1. sssd -d 9 -f -c /tmp/sssd.conf

2. # systemctl stop sssd.service
# ps ax | grep sssd
18140 ?        Ss     0:00 sssd -d 9 -f -c /tmp/sssd.conf
18141 ?        S      0:00 /usr/libexec/sssd/sssd_be --domain LDAPTEST -d 0x77f0 --debug-to-files
18142 ?        S      0:00 /usr/libexec/sssd/sssd_nss -d 0x77f0 --debug-to-files
18143 ?        S      0:00 /usr/libexec/sssd/sssd_pam -d 0x77f0 --debug-to-files

3. # systemctl restart sssd.service
# ps ax | grep sssd
18140 ?        Ss     0:00 sssd -d 9 -f -c /tmp/sssd.conf
18141 ?        S      0:00 /usr/libexec/sssd/sssd_be --domain LDAPTEST -d 0x77f0 --debug-to-files
18142 ?        S      0:00 /usr/libexec/sssd/sssd_nss -d 0x77f0 --debug-to-files
18143 ?        S      0:00 /usr/libexec/sssd/sssd_pam -d 0x77f0 --debug-to-files
18333 ?        Ss     0:00 /usr/sbin/sssd -D -f
18334 ?        S      0:00 /usr/libexec/sssd/sssd_be --domain LDAPTEST --debug-to-files
18335 ?        S      0:00 /usr/libexec/sssd/sssd_nss --debug-to-files
18336 ?        S      0:00 /usr/libexec/sssd/sssd_pam --debug-to-files

Actual results:
Stopping sssd service doesn't kill existing sssd processes.

Expected results:


Additional info:
"service sssd stop" on RHEL6 kills manually run sssd processes.
Comment 2 Jakub Hrozek 2013-11-13 08:35:39 EST
That's not something sssd controls, it's a feature of systemd. I just tried it with httpd as well and it's the same "issue".

Closing. Please reopen this bug against systemd if you don't like the current behaviour.
Comment 3 Kaushik Banerjee 2013-11-13 09:52:04 EST
sssd can be started from cmdline but needs to be killed from cmdline since systemctl cannot stop the process starting from cmdline.

This is a change in behaviour from RHEL6.

Re-opening this bug to have this documented in release note and IPA installation guide.
Comment 4 Jakub Hrozek 2013-11-13 09:59:07 EST
(In reply to Kaushik Banerjee from comment #3)
> sssd can be started from cmdline but needs to be killed from cmdline since
> systemctl cannot stop the process starting from cmdline.
> 
> This is a change in behaviour from RHEL6.
> 
> Re-opening this bug to have this documented in release note and IPA
> installation guide.

Kaushik, this is not a change in behaviour in sssd and there is nothing we can do about this. Please reassign to systemd if you think this requires documentation. Thanks.
Comment 5 Jenny Galipeau 2013-11-13 12:48:13 EST
We need to make sure that man pages and documentation are updated to reflect that sssd can not be started this way ... remove references to it etc ...  It would also be nice to fail with an appropriate message.
Comment 6 Jakub Hrozek 2013-11-13 12:53:42 EST
(In reply to Jenny Galipeau from comment #5)
> We need to make sure that man pages and documentation are updated to reflect
> that sssd can not be started this way ... remove references to it etc ... 
> It would also be nice to fail with an appropriate message.

SSSD *can* be started manually, it just needs to be stopped manually as well, either with Ctrl+C on the command line or by sending SIGTERM to the monitor process.

If you start SSSD with one mechanism (manually) you can't stop it with another mechanism (systemctl). That's expected. We never documented this worked and frankly I'd consider the new behaviour an improvement.

We can discuss tomorrow on the meeting..
Comment 7 Dmitri Pal 2013-11-14 09:05:08 EST
Decision: close this one and open a doc bug against systemd.

Note You need to log in before you can comment on or make changes to this bug.