Bug 1029879 - remediation text is shown in case of result XCCDF_RESULT_PASS
remediation text is shown in case of result XCCDF_RESULT_PASS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openscap (Show other bugs)
20
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Šimon Lukašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 08:02 EST by Petr Hracek
Modified: 2014-01-23 06:17 EST (History)
7 users (show)

See Also:
Fixed In Version: openscap-1.0.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 06:17:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Hracek 2013-11-13 08:02:01 EST
Description of problem:
When the SCE check script return XCCDF_RESULT_PASS and remediation is not script but remediation text then the text is shown html and xml output. But it should not be.

Version-Release number of selected component (if applicable):
openscap-0.9.11

How reproducible:


Steps to Reproduce:
1. copy files all-xccdf.xml and selinux.sh into some location
2. oscap xccdf eval --results all-xccdf-tmp.xml --profile xccdf_preupg_profile_default --report all-xccdf-tmp.html all-xccdf.xml
3.

Actual results:
solution text is shown in case of XCCDF_RESULT_PASS

Expected results:
solution text should be either hidden or not available

Additional info:
It is under discussion whether this behaviour is correct. I think that solution text should not be shown.
Comment 3 Šimon Lukašík 2013-12-20 08:19:11 EST
Fixed upstream. 19a37e8afbc27cc6a80c1e706ff254b408b8627f

Will became a part of next update.
Comment 4 Fedora Update System 2014-01-10 05:30:50 EST
openscap-1.0.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/openscap-1.0.2-1.fc20
Comment 5 Fedora Update System 2014-01-11 03:39:48 EST
Package openscap-1.0.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openscap-1.0.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0618/openscap-1.0.2-1.fc20
then log in and leave karma (feedback).
Comment 6 Petr Hracek 2014-01-13 04:56:11 EST
I tested the problem and it seems that Remediation Instructions are still shown in case of XCCDF_RESULT_PASS. Is this expected state?

Shall I reopen bug?
Comment 7 Šimon Lukašík 2014-01-13 05:38:00 EST
I cannot reproduce your problem. We need more information. I have used 
openscap-1.0.2 and run following two commands command:


  $ cat > selinux.sh <<__END__
#!/bin/bash
exit \$XCCDF_RESULT_PASS
__END__
  $ oscap xccdf eval --results /tmp/blah.xml --report /tmp/blah.html \
  all-xccdf.xml

And the report does not the remediation instruction. What should I have
done differently to exhibit the bug?
Comment 9 Šimon Lukašík 2014-01-14 06:30:41 EST
Thank you for confirmation!
Comment 10 Fedora Update System 2014-01-14 12:36:40 EST
openscap-1.0.3-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/openscap-1.0.3-1.fc20
Comment 11 Fedora Update System 2014-01-23 06:17:48 EST
openscap-1.0.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.