Bug 102990 - (ACPI) installer hangs on nForce 2 board
Summary: (ACPI) installer hangs on nForce 2 board
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: beta1
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-24 13:36 UTC by Mikel Ward
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-24 23:56:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikel Ward 2003-08-24 13:36:21 UTC
Description of problem:
When attempting to install Red Hat Linux 9.0.93 (Severn) from CD-ROM
on my ASUS A7N8X Deluxe (nForce 2 chipset) mainboard, the installer
displays some normal kernel messages, changes to a text framebuffer
mode, displays some more messages, then appears to hang at
"Running /sbin/loader..." or similar.  This occurs whether using the
default graphical mode or the text mode (having specified linux text
at the prompt).

Comment 1 Mikel Ward 2003-08-24 14:47:00 UTC
I just tried the Red Hat Linux 9 (Shrike) installer.  It also hung
when using the default graphical mode, however I got past the media
check page and to the main installer menu when using the text mode
(I then aborted as I didn't actually want to install Shrike).

Comment 2 Jeremy Katz 2003-08-24 21:05:57 UTC
Does it work if you boot with 'linux acpi=off'?

Comment 3 Mikel Ward 2003-08-26 13:24:50 UTC
Yes, the installer reaches the media check screen if I disable ACPI. 
After this, the text mode appears to work fully, while the graphical mode 
hangs again after the media check. 
 

Comment 4 Michael Fulbright 2003-09-15 21:53:09 UTC
How far after the media check does the graphical install get? What is the last
output, for example?

Comment 5 Mikel Ward 2003-09-16 13:53:33 UTC
The last message I see is:
Waiting for start X server to start... log located in /tmp/X.log

Then the screen goes into suspend mode.

Further investigation suggests that XFree86's VESA driver does not
work with my video card, a GeForce FX 5200.  I will file a separate
bug for this.

In the text mode, the installer also does not correctly detect the
size of my SATA hard drive.  I will file a separate bug for this,
too.


Comment 6 Mikel Ward 2003-09-16 14:35:05 UTC
Adding (ACPI) to the summary as other ACPI related bugs have this.


Comment 7 Mikel Ward 2003-09-17 02:11:35 UTC
Created bug 104498 to deal with the X issues.  This one's about needing
acpi=off :-).


Comment 8 Len Brown 2004-03-24 22:31:44 UTC
Michael,
Any chance you can report if Fedora Core 2-test1 installer
is able to work w/o acpi=off on your nforce2 box?
Also, is "pci=noacpi" sufficient, or is "acpi=off" required?

thanks,
-Len



Comment 9 Mikel Ward 2004-03-24 23:56:00 UTC
Fedora Core 1 final worked fine.  Presume the problem is fixed.


Note You need to log in before you can comment on or make changes to this bug.