Bug 1029926 - Quota: New auxiliary mount seen post upgrade from Big Bend even though quota is disabled. [NEEDINFO]
Quota: New auxiliary mount seen post upgrade from Big Bend even though quota ...
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
2.1
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Susant Kumar Palai
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 09:32 EST by Gowrishankar Rajaiyan
Modified: 2016-09-17 08:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 05:34:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
spalai: needinfo? (saujain)


Attachments (Terms of Use)
sosreport (5.38 MB, application/x-zip)
2013-11-13 09:35 EST, Gowrishankar Rajaiyan
no flags Details

  None (edit)
Description Gowrishankar Rajaiyan 2013-11-13 09:32:54 EST
Description of problem: I installed Big Bend and created a replicate volume. Enabled quota and set limits. Since we do not support quota in rolling upgrade, I disable quota. Post upgrade I notice that the auxiliary mount exists even though quota is disabled for the volume.


Version-Release number of selected component (if applicable):
glusterfs-server-3.4.0.43rhs-1.el6rhs.x86_64

How reproducible: Always


Steps to Reproduce:
1. Install Big Bend.
2. Enable quota and limit usage (which is tech preview)
3. Disable quota and chkconfig glusterd off
4. service glusterd stop; pkill glusterfs; pkill glusterfsd
5. yum update -y
6. reboot
7. login and do chkconfig glusterd on
8. service glusterd start
9. Check the output of "df -h"

Actual results: Auxiliary mount exists even though quota is disabled.


Expected results: There should be not auxiliary mount since quota is disabled.


Additional info:
[root@server1 ~]# gluster vol info
 
Volume Name: shanks-vol
Type: Replicate
Volume ID: 4151f8a4-57bc-4ad4-85c1-9e00fdf40a59
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp
Bricks:
Brick1: 10.70.42.214:/rhs/disk1/brick1
Brick2: 10.70.42.209:/rhs/disk1/brick1
Options Reconfigured:
features.quota: off
features.quota-deem-statfs: on
[root@server1 ~]# 


[root@server1 ~]# gluster vol quota shanks-vol list 
quota command failed : Quota is not enabled on volume shanks-vol
[root@server1 ~]# 


[root@server1 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/vda3              41G  2.1G   37G   6% /
tmpfs                  12G     0   12G   0% /dev/shm
/dev/vda1             485M   58M  402M  13% /boot
/dev/mapper/RHSS_vg-RHSS_lv1
                      400G  707M  400G   1% /rhs/disk1
/dev/mapper/RHSS_vg-RHSS_lv2
                       99G   33M   99G   1% /rhs/disk2
localhost:shanks-vol  400G  707M  400G   1% /var/run/gluster/shanks-vol <<<<<<<<<
[root@server1 ~]#
Comment 1 Gowrishankar Rajaiyan 2013-11-13 09:35:51 EST
Created attachment 823471 [details]
sosreport
Comment 3 Susant Kumar Palai 2014-01-05 23:52:03 EST
I couldn't reproduce the bug any more with current release.glusterfs 3.4.0.53rhs


[root@vm1 BIGBEND]# glusterfs --version
glusterfs 3.4.0.33rhs built on Sep  8 2013 13:20:25

[root@vm1 BIGBEND]# gluster volume info

Volume Name: test1
Type: Distribute
Volume ID: 5c41f023-fd6d-46ea-8317-3bf6c6df83e2
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.240:/brick2/a
Brick2: 192.168.122.240:/brick2/b
[root@vm1 BIGBEND]# gluster volume quota test1 ena
volume quota : success
[root@vm1 BIGBEND]# gluster volume quota test1 limit-usage /  1GB
volume quota : success

[root@vm1 BIGBEND]# gluster volume quota test1 disable
Disabling quota will delete all the quota configuration. Do you want to continue? (y/n) y
volume quota : success
[root@vm1 BIGBEND]# chkconfig glusterd off


[root@vm1 BIGBEND]# service glusterd stop 
Stopping glusterd:                                         [  OK  ]
[root@vm1 BIGBEND]# pkill glusterfs 
[root@vm1 BIGBEND]# pkill glusterfsd

[root@vm1 BIGBEND]# glusterfs --version
glusterfs 3.4.0.53rhs built on Dec 30 2013 10:10:43

After reboot
[root@vm1 ~]# chkconfig glusterd on
[root@vm1 ~]# service glusterd start
[root@vm1 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/vda1              14G  2.4G   11G  19% /
tmpfs                 499M     0  499M   0% /dev/shm
/dev/vda2             2.0G   67M  2.0G   4% /brick1
/dev/vda3             2.0G   35M  2.0G   2% /brick2
[root@vm1 ~]# 
[root@vm1 ~]# gvi
 
Volume Name: test1
Type: Distribute
Volume ID: 5c41f023-fd6d-46ea-8317-3bf6c6df83e2
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.122.240:/brick2/a
Brick2: 192.168.122.240:/brick2/b
Options Reconfigured:
features.quota: off

There was no auxiliary mount seen after updating glusterfs.
Comment 4 Susant Kumar Palai 2014-01-05 23:53:14 EST
Saurav, Can you reproduce the bug with latest build ?
Comment 5 Vijaikumar Mallikarjuna 2015-07-30 05:34:23 EDT
As per comment #3, not able to re-create the problem with 'glusterfs 3.4.0.53rhs'
Please file a new bug if the problem is seen in the latest build

Note You need to log in before you can comment on or make changes to this bug.