Bug 1029940 - Allow /var/log/mcelog to be read by more processes
Allow /var/log/mcelog to be read by more processes
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.6
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 10:07 EST by Denys Vlasenko
Modified: 2014-10-14 03:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-239.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:57:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denys Vlasenko 2013-11-13 10:07:55 EST
When oops is detected, abrt wants to save /var/log/mcelog file
to abrt's problem directory, but cannot: "Permission denied"

audit.log contains this:

type=AVC msg=audit(1384354858.293:185): avc:  denied  { read } for  pid=16409 comm="cp" name="mcelog" dev=dm-0 ino=917607 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mcelog_log_t:s0 tclass=file
type=SYSCALL msg=audit(1384354858.293:185): arch=40000003 syscall=5 success=no exit=-13 a0=bfecde59 a1=8000 a2=0 a3=1a4 items=0 ppid=16407 pid=16409 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="cp" exe="/bin/cp" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Please allow reading of this file from this context.

Or even from all contexts with uid=0: the file does not reveal any secrets. "Your DIMM#2 is having ECC errors" is not a security leak.
Comment 2 Daniel Walsh 2013-11-13 16:35:20 EST
a43e87245ed4347c35a69eac0900194d645098dc fixes this in git.
Comment 5 Lukas Vrabec 2014-07-02 07:52:20 EDT
$ sesearch -s abrt_t -t mcelog_log_t -c file -p read -A -C
Found 1 semantic av rules:
   allow abrt_t mcelog_log_t : file { ioctl read getattr lock open } ; 

I'll send patch.
Comment 8 errata-xmlrpc 2014-10-14 03:57:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1568.html

Note You need to log in before you can comment on or make changes to this bug.