This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 103 - RPM problem is really with triggers.
RPM problem is really with triggers.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
5.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-17 01:58 EST by rjwalsh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-11-19 10:12:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rjwalsh 1998-11-17 01:58:34 EST
rpm-2.5.3-5.1 dumps core when I try to upgrade certain
packages.  The packages in question were ypserv (upgrading
from the default release to 1.3.4-1) and samba (upgrading
from the default release to 1.9.18p7-2).  There are now
two entries in my rpm database for these packages, and I
can't erase either of them (nothing happens when I try.)

I have installed both the rpm and rpm-devel packages.
Comment 1 rjwalsh 1998-11-17 13:07:59 EST
Glint could not remove these packages either.  After I rebuilt the
RPM database, it no longer dumped core, but then again it did not
remove the entries from the database either.
Comment 2 Aleksey Nogin 1998-11-17 16:48:59 EST
I have the same problem

[root@... /root]# rpm -q rpm
rpm-2.5.3-5.1
[root@... /root]# rpm -q samba ypserv
samba-1.9.18p5-1
samba-1.9.18p7-2
samba-1.9.18p10-5
ypserv-1.3.1-2
ypserv-1.3.4-1
[root@... /root]# rpm -evv ypserv-1.3.1-2 samba-1.9.18p5-1
samba-1.9.18p7-2
D: counting packages to uninstall
D: opening database in //var/lib/rpm/
D: found 3 packages to uninstall
D: uninstalling record number 842648
D: uninstalling record number 1729880
D: uninstalling record number 4025432
[root@... /root]# rpm -q samba ypserv
samba-1.9.18p5-1
samba-1.9.18p7-2
samba-1.9.18p10-5
ypserv-1.3.1-2
ypserv-1.3.4-1
Comment 3 Bill Nottingham 1998-11-18 07:12:59 EST
Try 'rpm -e --notriggers <package>'. Does that help?
Comment 4 Aleksey Nogin 1998-11-18 12:11:59 EST
Thanks, rpm -e --notriggers worked!
Comment 5 Derek Tattersall 1998-11-19 10:12:59 EST
The problem is resolved in RH5.2, with ypserv and samba rpms that no
longer use triggers.  There were several other rpms that used
triggers, and they have been fixed also.

Note You need to log in before you can comment on or make changes to this bug.