Bug 1030 - mtools has trouble reading msdos disks
mtools has trouble reading msdos disks
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mtools (Show other bugs)
5.2
alpha Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-02 19:10 EST by ehm
Modified: 2013-09-04 10:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-29 16:39:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ehm 1999-02-02 19:10:04 EST
I tried all mtools versions shipped with RH 5.0 5.1 and 5.2.
I configured the /etc/mtools.conf file by hand.
I ruled out the disk drive and disks as a source of error.
I tried compiling mtools from the source with both gcc, and
egcs, makes no difference.
I tried tweaking the makefile with different compiler
options (eg. no optimization, etc...).  No difference.
Actually it could read the disks with mdir, but it
complained of file io errors when I tried to run mcopy.  The
same files could be read on i386 machines with the same
version of mtools.  The mtools work fine on our i386
machines, just doesn't want to work on our Alphas (we have
two, both running RH 5.2).  Any help is appreciated.
Comment 1 visser 1999-03-09 02:36:59 EST
check the write permission on /dev/fd0
(you'll probably find that mtools works fine if you are logged in as
 root)
a crude workaround is: su root, chmod o+w /dev/fd0, but be aware
that this makes the floppy writable by everyone...
Comment 2 Preston Brown 1999-03-29 16:39:59 EST
this has been fixed in the latest version of mtools in RawHide.  If
you would like, you can get a SRPM from there and compile it on 5.2,
or you can wait until Red Hat Linux 6.0 is released, which will have
the fixed mtools included.
Comment 3 CFME Bot 2013-09-04 10:33:44 EDT
Commit pushed to master at https://github.com/ManageIQ/cfme

https://github.com/ManageIQ/cfme/commit/0a2aaaf0306ca625a7bf8782879bbbd3ad76e1ca
Remove padding from custom logo in new CFME banner

Issue #1030
Bug 1001784

Note You need to log in before you can comment on or make changes to this bug.