Bug 103000 - should format before package selection
should format before package selection
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-24 20:41 EDT by Felix Miata
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:23:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Miata 2003-08-24 20:41:09 EDT
Description of problem:
Format early, right after setting mount points, so people don't waste so much
time if format fails. That's how Mandrake does it.

Version-Release number of selected component (if applicable):
9

How reproducible:
Didn't try

Steps to reproduce:
1.Attempt dd graphical NFS install
2.Spend considerable time on package selection
3.After format failure, see alert saying press <return> to reboot 
4.Click on OK button in alert
    
Actual results:
unexpected reboot

Expected results:
Asked me where to save package selection list before rebooting.

Additional info:
Except for formatting, I fully prepared /dev/sdc prior to booting from
bootdisk.img for an NFS install. Since this was my first RHL install since 7.3,
I spent considerable time in package selection, probably close to two hours.
Only after spending so much time did the installer attempt to format the
selected partitions. I had chosen to scan for bad blocks on /, so formatting
also took considerable additional time at this point. When 100% was reached, an
alert came up to say format failed due to excessive bad sectors, telling me to
press <enter> to reboot. I didn't want to reboot, as I expected some means to
save a package selection list. I clicked OK on the alert, and the system
rebooted immediately. After this failed install, I immediately ran IBM's DFT
program three times successfully on /dev/sdc, which means format should not have
failed.

53c875 SCSI
no ATA
K6/2-550 CPU
256MB PC100 SDRAM
SiS530 Chipset
Realtek 8139 NIC
Yamaha 744 Sound
Brand new install target device /dev/sdc IBM DPSS

Expected results really should be yet another enhancement request bug.
Comment 1 Jeremy Katz 2004-10-04 23:23:08 EDT
This is difficult to do without requiring more RAM.  With the current
installer framework, I'm not planning on changing this around.

Note You need to log in before you can comment on or make changes to this bug.