Bug 1030021 - Tracker for downstream RHS product: gfapi: introduce glfs_readdir() and glfs_readdirplus() APIs
Tracker for downstream RHS product: gfapi: introduce glfs_readdir() and glfs_...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs-devel (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 2.1.2
Assigned To: Raghavendra Talur
Sachidananda Urs
: ZStream
Depends On: 1044440
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 12:54 EST by Tushar Katarki
Modified: 2015-05-15 14:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.49rhs
Doc Type: Enhancement
Doc Text:
With this enhancement, the glfs_readdir and glfs_readdirplus calls based on POSIX readdir() are added in libgfapi. Earlier, Libgfapi had only the glfs_readdir_r() based on Posix's readdir_r().
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:03:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Program to test readdir / readdirplus (30.00 KB, application/x-tar)
2013-12-30 07:23 EST, Sachidananda Urs
no flags Details

  None (edit)
Description Tushar Katarki 2013-11-13 12:54:49 EST
Description of problem:

This is a downstream bug to track the following fix: http://review.gluster.org/#/c/6201/

which is a fix in response to this http://lists.gnu.org/archive/html/gluster-devel/2013-10/msg00082.html

required for testing and validation of libvirt with RHS 2.1.
Comment 2 Raghavendra Talur 2013-12-04 04:19:36 EST
Patch posted downstream at
https://code.engineering.redhat.com/gerrit/#/c/16779/
Comment 3 Sachidananda Urs 2013-12-30 07:23:15 EST
Created attachment 843367 [details]
Program to test readdir / readdirplus
Comment 4 Sachidananda Urs 2013-12-30 07:27:01 EST
Tested with attached program. I can use glfs_readdir and glfs_readdirplus with the latest build.
Comment 6 Pavithra 2014-01-06 05:44:04 EST
Can you please verify the doc test?
Comment 7 Raghavendra Talur 2014-01-06 06:10:36 EST
Doc text is accurate.
Comment 9 errata-xmlrpc 2014-02-25 03:03:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.