Bug 103004 - chsh to /bin/sh leaves shell field of /etc/passwd blank
Summary: chsh to /bin/sh leaves shell field of /etc/passwd blank
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-25 06:41 UTC by UQ Business School
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 17:36:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description UQ Business School 2003-08-25 06:41:19 UTC
Description of problem:

/usr/bin/chsh leaves the shell field of /etc/passwd blank, after the shell is
changed to /bin/sh.

In some ways this isn't a bug, since a null shell field is supposed to be
equivalent to /bin/sh.  But it seems strange for chsh to deliberately use null
instead of /bin/sh.

The vsftpd server will not run if the shell assigned to user "ftp" is a null
string. This may be a bug, or it may just be acceptable level of paranoia.

This problem was discovered when using  chsh -s /bin/sh ftp


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. chsh -s /bin/sh someuser
2. egrep '^someuser' /etc/passwd
3.
    
Actual results:
last field of passwd is blank

Expected results:
last field should contain /bin/sh

Additional info:

Comment 1 Elliot Lee 2003-09-05 17:36:37 UTC
Fix is in CVS and should appear in rawhide eventually.


Note You need to log in before you can comment on or make changes to this bug.