Bug 1030040 - Ads and 3rd party tracking in TLS section of rsyslog documentation
Ads and 3rd party tracking in TLS section of rsyslog documentation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rsyslog7 (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Tomas Heinrich
Dalibor Pospíšil
: Documentation, EasyFix, Patch
Depends On:
Blocks: 1030041 1030043 1030044
  Show dependency treegraph
 
Reported: 2013-11-13 14:11 EST by Filip Krska
Modified: 2014-10-14 03:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1030041 1030043 1030044 1227287 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:30:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (9.23 KB, patch)
2013-11-18 07:19 EST, Marcel Kolaja
no flags Details | Diff

  None (edit)
Description Filip Krska 2013-11-13 14:11:49 EST
Description of problem:

There are unsolicited ads loaded from 3rd party servers (implies unsolicited and unexpected tracking by the 3rd party, so privacy concerns may apply) via following markup:

<span style="float: left">
<script type="text/javascript"><!--
google_ad_client = "pub-3204610807458280";
/* rsyslog doc inline */
google_ad_slot = "5958614527";
google_ad_width = 125;
google_ad_height = 125;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</span>

in following doc pages:

/usr/share/doc/rsyslog-4.6.2/rsyslog_secure_tls.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_errmsgs.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_ca.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_machine.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_scenario.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_server.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_client.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_udp_relay.html
/usr/share/doc/rsyslog-4.6.2/tls_cert_summary.html


Version-Release number of selected component (if applicable):

All versions (RHEL 5,6,7, latest Fedora affected)

How reproducible:

Allways

Steps to Reproduce:
1. browse e.g. file:///usr/share/doc/rsyslog-5.8.10/rsyslog_secure_tls.html with web browser

Actual results:

Ads are loaded from http://pagead2.googlesyndication.com

Expected results:

No http request to 3rd party site is performed, no ads displayed when browsing local docs

Additional info:
Comment 1 Tomas Heinrich 2013-11-14 09:40:45 EST
Good catch, thanks.
Comment 2 Marcel Kolaja 2013-11-18 07:19:25 EST
Created attachment 825574 [details]
proposed patch
Comment 3 Tomas Heinrich 2013-11-18 10:45:25 EST
Thanks for the patch, I've already sent a variation of it patch to upstream. They need to review whether there aren't any other glitches and when they merge, I'll use the final version.
Comment 8 errata-xmlrpc 2014-10-14 03:30:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1540.html

Note You need to log in before you can comment on or make changes to this bug.