Bug 1030047 - Response time gadget doesn't filter correctly when > 1 gadget per tab
Response time gadget doesn't filter correctly when > 1 gadget per tab
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Eric Wittmann
Andrej Vano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 14:42 EST by Alan Santos
Modified: 2015-02-05 20:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of un-populated drop-down (218.38 KB, image/png)
2013-11-13 14:43 EST, Alan Santos
no flags Details

  None (edit)
Description Alan Santos 2013-11-13 14:42:54 EST
Description of problem:
When adding a second response time gadget the drop-downs do not populate correctly. 




How reproducible:
always


Steps to Reproduce:
1.Add one response time gadget. 
2.select a service to watch
3.add another
4. can't be configured as drop downs aren't populated (see screenshot)



Expected results:

Can watch >1 discrete service on a single tab.

Additional info:
Comment 1 Alan Santos 2013-11-13 14:43:21 EST
Created attachment 823624 [details]
screenshot of un-populated drop-down
Comment 3 Eric Wittmann 2013-11-13 17:34:53 EST
The gadget server was using IDs to find and manipulate the gadget preference drop-down widgets.  This is problematic in HTML5 because multiple IDs isn't cool.  I changed the IDs to class names, and modified the code that looks them up.

https://github.com/Governance/gadget-server/pull/23

This fix should be included in the ER7-2 tag that I hope is coming soon.
Comment 4 Andrej Vano 2013-12-13 03:13:28 EST
Hello,

it's working as expected on ER7-2

Note You need to log in before you can comment on or make changes to this bug.