Bug 1030069 - [RFE] packstack should allow for cinder share mount options
[RFE] packstack should allow for cinder share mount options
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
medium Severity medium
: z4
: 4.0
Assigned To: Gilles Dubreuil
yeylon@redhat.com
storage
: FutureFeature, ZStream
Depends On:
Blocks: 1040649 1045196
  Show dependency treegraph
 
Reported: 2013-11-13 16:05 EST by Steve Reichard
Modified: 2016-04-26 11:48 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 22:09:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Reichard 2013-11-13 16:05:31 EST
Description of problem:

I greatly appreciate packstack adding the support to configure glusterfs as a backend to cinder.

One feature to enhance it would be to allow options to be specified.

I work around this by issuing this command, since the one option I care about is backupvolfile-server.

ssh ${CONFIG_CINDER_HOST} "sed 's/^172.31.143.91:\\/OSTACKcinder\$/172.31.143.91:\\/OSTACKcinder  -o backupvolfile-server=172.31.143.92/' /etc/cinder/shares.conf"


Version-Release number of selected component (if applicable):

[root@cvd1 site-packages]# yum list installed | grep packstack
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
openstack-packstack.noarch     2013.2.1-0.9.dev840.el6ost
[root@cvd1 site-packages]# 


How reproducible:



Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Gilles Dubreuil 2014-03-11 22:35:03 EDT
My understanding is Packstack's scope is all-in-one deployment type, even though it can handle few other scenarios.

If that is confirmed then this RFE is not going to be honored and foreman deployment should be used. 

Effectively there is no much need for glusterfs storage in such case, well besides testing but that's not user driven.
Comment 4 Gilles Dubreuil 2014-03-12 22:09:17 EDT
Steve, 

Would it be okay to drop this from Packstack?

The target of simplifying Packstack is to make it maintainable. If we keep implementing things like this we will never make it happen.

Note You need to log in before you can comment on or make changes to this bug.