Bug 103007 - authconfig breaks /etc/{,openldap/}ldap.conf
Summary: authconfig breaks /etc/{,openldap/}ldap.conf
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: authconfig   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-25 08:06 UTC by Piero Calucci
Modified: 2013-07-02 22:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 08:36:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Piero Calucci 2003-08-25 08:06:09 UTC
Description of problem:

authconfig writes bad baseDN for ldap authentication in /etc/ldap.conf and
/etc/openldap/ldap.conf

Version-Release number of selected component (if applicable): 4.2.12-3


How reproducible: always


Steps to Reproduce:
1. launch authconfig
2. select "use ldap" in User Information Configuration and Authentication
Configuration
3. write dc=my,dc=domain in base DN
    
Actual results:

base dc=my.dc=domain in /etc/ldap.conf
BASE dc=my.dc=domain in /etc/openldap/ldap.conf

Expected results:

base dc=my,dc=domain in /etc/ldap.conf
BASE dc=my,dc=domain in /etc/openldap/ldap.conf

Additional info:

prevents ldap authentication; breaks ldap clients

Comment 1 Nalin Dahyabhai 2003-08-26 12:37:10 UTC
Works for me.  Are you quite certain that it was typed in correctly?

Comment 2 Nalin Dahyabhai 2003-08-26 12:42:24 UTC
4.2.12-3 was shipped in RHL 8.0, not 9.  Changing version.


Note You need to log in before you can comment on or make changes to this bug.