Bug 1030072 - [abrt] libreoffice-core-4.1.3.2-4.fc19: comphelper::getProcessServiceFactory: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
[abrt] libreoffice-core-4.1.3.2-4.fc19: comphelper::getProcessServiceFactory:...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:90cb098c56b7a63cd10f8661d93...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 16:19 EST by Paul Grabbe
Modified: 2014-03-06 08:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 08:58:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (47.82 KB, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: cgroup (141 bytes, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: core_backtrace (17.74 KB, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: dso_list (18.14 KB, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: environ (3.60 KB, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: maps (93.46 KB, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: open_fds (558 bytes, text/plain)
2013-11-13 16:19 EST, Paul Grabbe
no flags Details
File: proc_pid_status (929 bytes, text/plain)
2013-11-13 16:20 EST, Paul Grabbe
no flags Details
File: Screenshot from 2013-11-13 14:29:56.png (24.98 KB, application/octet-stream)
2013-11-13 16:20 EST, Paul Grabbe
no flags Details
tarball of ~/.config/libreoffice/4/user/uno_packages/ (39.26 KB, application/gzip)
2013-11-13 17:11 EST, Paul Grabbe
no flags Details

  None (edit)
Description Paul Grabbe 2013-11-13 16:19:22 EST
Description of problem:
Libreoffice won't start after update. Same error in KDE and Gnome Classic environments. Problem persists after deinstall and reinstall of all Libreoffice packages. Kind of strange as I have two other desktops and a laptop without this problem. All four system are fully up to date via yum. Perhaps there is an interaction with some other package.

Version-Release number of selected component:
libreoffice-core-4.1.3.2-4.fc19

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc --splash-pipe=5
crash_function: comphelper::getProcessServiceFactory
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.11.7-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: Nov 13 14:41:35 localhost abrt-hook-ccpp[2141]: Saved core dump of pid 2138 (/usr/lib64/libreoffice/program/soffice.bin) to /var/tmp/abrt/ccpp-2013-11-13-14:41:34-2138 (27361280 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 comphelper::getProcessServiceFactory at /usr/src/debug/libreoffice-4.1.3.2/comphelper/source/processfactory/processfactory.cxx:65
 #7 comphelper::getProcessComponentContext at /usr/src/debug/libreoffice-4.1.3.2/comphelper/source/processfactory/processfactory.cxx:97
 #8 utl::DefaultFontConfiguration::DefaultFontConfiguration at /usr/src/debug/libreoffice-4.1.3.2/unotools/source/config/fontcfg.cxx:106
 #9 get at /usr/src/debug/libreoffice-4.1.3.2/include/rtl/instance.hxx:393
 #10 utl::DefaultFontConfiguration::get at /usr/src/debug/libreoffice-4.1.3.2/unotools/source/config/fontcfg.cxx:98
 #11 ImplStyleData::SetStandardStyles at /usr/src/debug/libreoffice-4.1.3.2/vcl/source/app/settings.cxx:378
 #12 ImplStyleData::ImplStyleData at /usr/src/debug/libreoffice-4.1.3.2/vcl/source/app/settings.cxx:247
 #13 StyleSettings::StyleSettings at /usr/src/debug/libreoffice-4.1.3.2/vcl/source/app/settings.cxx:467
 #14 ImplAllSettingsData::ImplAllSettingsData at /usr/src/debug/libreoffice-4.1.3.2/vcl/source/app/settings.cxx:1331
 #15 AllSettings::AllSettings at /usr/src/debug/libreoffice-4.1.3.2/vcl/source/app/settings.cxx:1383
Comment 1 Paul Grabbe 2013-11-13 16:19:31 EST
Created attachment 823639 [details]
File: backtrace
Comment 2 Paul Grabbe 2013-11-13 16:19:34 EST
Created attachment 823640 [details]
File: cgroup
Comment 3 Paul Grabbe 2013-11-13 16:19:40 EST
Created attachment 823641 [details]
File: core_backtrace
Comment 4 Paul Grabbe 2013-11-13 16:19:43 EST
Created attachment 823642 [details]
File: dso_list
Comment 5 Paul Grabbe 2013-11-13 16:19:47 EST
Created attachment 823643 [details]
File: environ
Comment 6 Paul Grabbe 2013-11-13 16:19:50 EST
Created attachment 823644 [details]
File: limits
Comment 7 Paul Grabbe 2013-11-13 16:19:54 EST
Created attachment 823645 [details]
File: maps
Comment 8 Paul Grabbe 2013-11-13 16:19:57 EST
Created attachment 823646 [details]
File: open_fds
Comment 9 Paul Grabbe 2013-11-13 16:20:00 EST
Created attachment 823647 [details]
File: proc_pid_status
Comment 10 Paul Grabbe 2013-11-13 16:20:04 EST
Created attachment 823648 [details]
File: Screenshot from 2013-11-13 14:29:56.png
Comment 11 Stephan Bergmann 2013-11-13 17:00:51 EST
Error message from attachment 823648 [details] screenshot is "InvalidRegistryException: file:///usr/lib64/libreoffice/program/services/services.rdb: duplicate <implementation name='com.sun.star.comp.GraphicExportDialog'>".

This is most probably due to some extension installed per-user in this LibreOffice installation.

Paul, can you make available a tarball of your ~/.config/libreoffice/4/user/uno_packages/ directory (either as an attachment here or as a mail directly to me)?
Comment 12 Paul Grabbe 2013-11-13 17:11:31 EST
Created attachment 823652 [details]
tarball of ~/.config/libreoffice/4/user/uno_packages/

requested tarball attached.
Comment 13 Stephan Bergmann 2013-11-13 17:31:25 EST
So you indeed have an extension EnhancedGraphicExportDialogs.oxt installed (presumably obtained from <http://extensions.openoffice.org/de/project/enhanced-export-options-bitmap-files>) that illegally reuses a core implementation ID.  I'll try to contact its author for a fixed version.

In the meantime, as that was apparently the only per-user installation you had installed, I'd suggest to "rm -rf ~/.config/libreoffice/4/user/uno_packages" (while LibreOffice is not running) and use LibreOffice without that extension for now.
Comment 14 Paul Grabbe 2013-11-13 17:36:00 EST
Bingo! That fixed it. Thanks for the quick help.

Interesting that this did not arise until the latest Libreoffice update was applied.
Comment 15 Stephan Bergmann 2014-03-06 08:58:23 EST
Closing as CANTFIX as the problem is in a third-party LibreOffice extension we have no control over in Fedora.

Note You need to log in before you can comment on or make changes to this bug.