Bug 1030104 - [GSS] (6.2.x) segfault and other xnio issues running on IBM JDK on IBM-I
[GSS] (6.2.x) segfault and other xnio issues running on IBM JDK on IBM-I
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Remoting (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: EAP 6.2.1
Assigned To: David M. Lloyd
Jitka Kozana
Russell Dickenson
:
Depends On: 1052258
Blocks: eap62-cp01-blockers 1040879
  Show dependency treegraph
 
Reported: 2013-11-13 17:52 EST by Brad Maxwell
Modified: 2014-02-24 15:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An issue with applications running on IBM systems failing with a segmentation fault has been corrected in this release of JBoss EAP 6. The crashes were caused by NIO implementations in IBM JDKs that are optimized for usage on IBM operating systems. The I/O layer in JBoss EAP attempts to detect and utilize these implementations. However on some operating systems (like IBM-I) these implementations cause a segfault. In this release of the product, these operating systems are detected and safe fall-backs are utilized. This resolves the segmentation fault issue and the application server no longer crashes unexpectedly.
Story Points: ---
Clone Of:
: 1052258 (view as bug list)
Environment:
Last Closed: 2014-02-24 15:14:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Maxwell 2013-11-13 17:52:46 EST
- Do not try to use optimized selector providers on OS/400 since that can cause a segfault
-  Do not specify SSL provider because IBM does not have this one 
- Do not recurse when old locking is in effect
Comment 4 Scott Mumford 2014-01-20 00:50:18 EST
Marking for inclusion in 6.2.1 release notes documentation.
Comment 5 Scott Mumford 2014-01-22 21:21:25 EST
Requesting information on the underlying causes and fixes of the problems listed in the description for release note text.

Any and all details supplied are appreciated.
Comment 6 Scott Mumford 2014-01-23 19:21:11 EST
Thanks for the great content David. Formatted and marked for publication in the Release Notes.
Comment 7 Jitka Kozana 2014-01-27 06:30:50 EST
Verified.

Note You need to log in before you can comment on or make changes to this bug.