Bug 1030139 - zanata-cli does not respond to batch flag (-B or --batch-mode)
zanata-cli does not respond to batch flag (-B or --batch-mode)
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-zanata-client (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 20:46 EST by David Mason
Modified: 2015-07-28 22:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 22:46:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-11-13 20:46:28 EST
Description of problem:
When running zanata-cli push, adding -B or --batch-mode does not prevent the confirmation prompt "are you suer (y/n)?" being displayed and pausing client execution. This makes the client useless in automated jobs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. prepeare zanata.xml for any project
2. run zanata-cli push -B with appropriate source and target directories

Actual results:
command pauses with the prompt "are you sure (y/n)?"


Expected results:
command runs to completion then terminates.


Additional info:
Comment 1 David Mason 2013-11-13 21:50:48 EST
The -B option works if positioned before the sub-command, e.g. zanata-cli -B push.

This appears similar to behaviour of the -e and -X option as noted in https://bugzilla.redhat.com/show_bug.cgi?id=1003444
Comment 2 Ding-Yi Chen 2014-12-17 18:52:53 EST
It looks like a duplicate of 1003444.

David, thanks for point this out.

*** This bug has been marked as a duplicate of bug 1003444 ***
Comment 3 David Mason 2014-12-18 18:14:26 EST
Re-opening because this is not a duplicate of bug 1003444 - that bug does not mention the -B flag at all, and the fix may not necessarily be the same.
Comment 4 Zanata Migrator 2015-07-28 22:46:39 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-186

Note You need to log in before you can comment on or make changes to this bug.