Bug 1030208 - Unable to create hardlinks when the source and destination are in the same directory.
Unable to create hardlinks when the source and destination are in the same di...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1024459
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 02:25 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1024459
Environment:
Last Closed: 2014-04-17 09:15:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-11-14 03:34:41 EST
REVIEW: http://review.gluster.org/6262 (fuse: Check the return status from state->resolve_now) posted (#1) for review on master by Vijaikumar M (vmallika@redhat.com)
Comment 2 Niels de Vos 2014-04-17 09:15:00 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.