Bug 1030239 - Inappropriately shown Connection Reset page
Inappropriately shown Connection Reset page
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 03:42 EST by Maros Zatko
Modified: 2013-12-12 05:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 05:53:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maros Zatko 2013-11-14 03:42:11 EST
Description of problem:
I've visited http://webapp.etsi.org/key/key.asp?full_list=y
which is a very long list of standards. After some time of loading I was
able to see a long list and was able to scroll down as it was loading.
Then, suddenly browser changed its mind, *wiped* all the content I was waiting for to see and stupidly shown me "The connection was reset" page.


Version-Release number of selected component (if applicable):
Firefox 25


How reproducible:
always

Steps to Reproduce:
1. go to http://webapp.etsi.org/key/key.asp?full_list=y
2. wait for your content
3. go away disappoint seeing very unuseful page without the content you've been waiting for.

Actual results:
Connection reset page

Expected results:
Partially loaded content with unobtrusive and clear distinction that the content is partial and that server did not cooperate.

Additional info:
Please bear in mind that this was not-so-bad as it took only about two minutes. I don't want to imagine ones rage if he/she would see this after 20 minutes loading somewhere in the middle of nowhere on a very bad connection (think GSM/GPRS/something worse) where this behaviour could even mean loss of life.
Comment 1 Martin Stransky 2013-12-11 13:21:00 EST
I can't reproduce with Firefox 26. Can you check it again? (eventually in safe-mode).
Comment 2 Maros Zatko 2013-12-12 05:50:51 EST
Tried it other day, but the server was responsive :(

I also tried to create offending mock server which would reproduce similar condition/situation (sending X bytes and closing client socket in mid-transfer) but was unsuccessful -- the browser (this time it's FF 23.0.1) keeps showing me partially loaded content. I guess it needs some kind of other factor (network condition; malfunction maybe) to kick in.

Any ideas?
Comment 3 Martin Stransky 2013-12-12 05:53:23 EST
Okay, let's say it's just some special case....

Note You need to log in before you can comment on or make changes to this bug.