Bug 1030287 - Cannot change password [NEEDINFO]
Cannot change password
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Management Console (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 04:54 EST by Anton
Modified: 2015-05-14 21:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-03 11:12:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jliggitt: needinfo? (software)


Attachments (Terms of Use)

  None (edit)
Description Anton 2013-11-14 04:54:14 EST
Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Forgot password, thus requested it be reset
2. Tried to change password

Actual results:

Get technical error page with the following reference.

Reference #4ca3ad7d1ad840f419612229c26f6b29

Expected results:
Should be able to change password without errors.


Additional info:
Comment 1 Yujie Zhang 2013-11-14 05:07:46 EST
Can not reproduce it on PROD using my account yujzhang+3@redhat.com.
Comment 3 Jordan Liggitt 2013-11-14 09:33:53 EST
Password reset is working for me now. Can you still recreate?
Comment 4 Anton 2013-11-14 10:16:31 EST
Yes, I can still reproduce this.

Still unable to change password.

Still getting error.

Here is the error reference. Reference #bb0d28dc6323fef552420fb370bb9831

May I request that you re-open this.
Comment 5 Jordan Liggitt 2013-11-14 10:21:30 EST
We're seeing some errors in the authentication integration.

Can you try logging in here:
  https://www.redhat.com/wapps/sso/login.html
and resetting your password here:
  https://www.redhat.com/wapps/ugc/protected/password.html
Comment 6 Jordan Liggitt 2013-11-14 10:33:17 EST
Also, what is your login id?
Comment 7 software 2013-11-22 10:09:19 EST
I'm having the same issue.

Steps to reproduce: 
1- In Openshift online, I go to My Account page. (https://openshift.redhat.com/app/account)
2- Press the grey "Change password..." button.
3- Appears the change password screen (https://openshift.redhat.com/app/account/password/edit) 
4- Type the old and new pass twice, press the blue Change Password button
5- Appears the generic error page: "We appear to be having technical difficulties"
Comment 8 Jordan Liggitt 2013-11-22 10:11:05 EST
Thanks, are you able to log in at https://www.redhat.com/wapps/sso/login.html
and change your password at https://www.redhat.com/wapps/ugc/protected/password.html
Comment 9 software 2013-11-22 10:16:52 EST
Hi Jordan,

I tried to log in there, but I had to create a new account. 
It seems it is a different "place".
So I don't know changing the password here will be useful for this.
Comment 10 Jordan Liggitt 2013-12-02 15:15:39 EST
We're having trouble recreating this. If you log out of the site and log back in to https://openshift.redhat.com/app/console, can you change your password then?
Comment 11 Fabiano Franz 2014-01-03 11:12:53 EST
Unable to recreate. Will be reopened if the user provides answer to 'needinfo'.

Note You need to log in before you can comment on or make changes to this bug.