Bug 1030298 - Invalid parameter quantum_metadata_proxy_shared_secret while installing with packstack
Invalid parameter quantum_metadata_proxy_shared_secret while installing with ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: z3
: 3.0
Assigned To: Martin Magr
Nir Magnezi
: TestBlocker, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 05:06 EST by Attila Darazs
Modified: 2014-01-09 14:40 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.37.dev705.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 10:20:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 56366 None None None Never

  None (edit)
Description Attila Darazs 2013-11-14 05:06:47 EST
Description of problem:
The installation fails on a packstack error:

ERROR : Error during puppet run : Error: Invalid parameter
quantum_metadata_proxy_shared_secret at
/var/tmp/packstack/9e09ecdc2750465592f062da88fb5843/manifests/192.168.0.133_api_nova.pp:9
on node jenkins-rhos-3.openstacklocal

Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.35.dev699.el6ost.noarch (in OpenStack-Grizzly Puddle: 2013-11-13.1)

How reproducible:
Always

Steps to Reproduce:
I think it's enough if you install with the quantum install disabled (CONFIG_QUANTUM_INSTALL=n), but we have a test reproducer if it's necessary.
Comment 2 Rami Vaknin 2013-11-14 05:18:02 EST
I've tested it, it reproduces also with CONFIG_QUANTUM_INSTALL=y
Comment 7 Rami Vaknin 2013-11-16 15:32:35 EST
Verified on rhos Grizzly puddle 2013-11-14.2.
Comment 8 errata-xmlrpc 2013-11-18 10:20:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1510.html

Note You need to log in before you can comment on or make changes to this bug.