Bug 103030 - rapid mouse movement causes X server crash
rapid mouse movement causes X server crash
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
http://tibbitts.freeshell.org/tech/XF...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-25 13:50 EDT by Paul Tibbitts
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Toshiba 1555 Satellite config (3.17 KB, text/plain)
2003-08-28 12:55 EDT, Paul Tibbitts
no flags Details
result of termination of x server on toshiba 1555 (29.71 KB, text/plain)
2003-08-28 12:57 EDT, Paul Tibbitts
no flags Details

  None (edit)
Description Paul Tibbitts 2003-08-25 13:50:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4) Gecko/20030624
Netscape/7.1

Description of problem:
Rapid movement of mouse around screen, illustrated by dragging a window like an
xterm around the screen rapidly (rapid being something you might do routinely,
not just something you would try to break the server) results in X server
crashing (see URL).  Does not crash with slow mouse movement.

Not sure if related, but rapid mouse movement between two windows results in
infinite loop with control switching a couple of times per second between both
windows.  This latter problem can be cured by right-clicking on either of the
window borders to select one or the other - does not cause server crash.

URL shows specific X server diag output from Toshiba 1555CDS laptop.  Have tried
default "accel" and "noaccel" options, same results.

NOTE: am using same window manager and personal (non-XF86Config) files on other
computers (sharing home directories) and am not experiencing same problem, but
those computers have totally different video cards.  Other cards are C&T and
older S3.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. startx
2. bring up xterm or similar window
3. drag xterm around screen
    

Actual Results:  X server crashes, control returns to text terminal.

Expected Results:  Window should move around screen.

Additional info: Used same laptop with RH 6.x through all versions of 7.x, no
problem.  Also used 8.0, don't think this problem occured but only used for
short time before upgrading to 9.
Comment 1 Michael Lee Yohe 2003-08-26 17:31:50 EDT
You may want to try a later version of XFree86 (from Rawhide, for example) to
see if your bug has already been wiped out by a later revision.
Comment 2 Mike A. Harris 2003-08-27 04:00:22 EDT
Please attach X server log and config file from when the problem occurs.
If it occurs on multiple systems or with multiple video hardware, and you
can provide individual configs and logs, please attach all of them well
labeled to the bug report as individual uncompressed file attachments
using bugzilla's file attachment feature below.
Comment 3 Mike A. Harris 2003-08-27 04:01:29 EDT
Reassigning to proper component (XFree86).  Note that XFree86-Servers-3.3.6,
which this was filed against, last appeared in Red Hat Linux 7.3.  Just
a note...
Comment 4 Paul Tibbitts 2003-08-27 17:38:51 EDT
The files are in 

http://tibbitts.freeshell.org/tech/XF86Config

http://tibbitts.freeshell.org/tech/XFree86.0.log

I saw that the version I reported was wrong but it was the only choice presented
in the form as far as I could tell.  This was the first time I'd tried the
java-based interface, probably I just did something wrong. Anyway thanks for
fixing it.
Comment 5 Mike A. Harris 2003-08-28 03:52:06 EDT
Attach the files directly to the bug report using bugzilla's file attachment
feature, or I can not investigate this any further.  The reason for this,
is that the majority of bugs that get reported take a while to fix, and 
when we request information, we need that information to be permanently
available for the life of the bug report until it is resolved.  The files
at the URL you posted however might disappear at any time, and are highly
likely to not be permanent.  We have no way of permanently tracking files
that are not stored in our bugzilla tracking database.

Click on the "Create a New Attachment" link below, and attach one file
at a time as individual uncompressed file attachments.  Once this is
completed, I'll be happy to examine the files and investigate the report.
Comment 6 Paul Tibbitts 2003-08-28 12:55:50 EDT
Created attachment 94041 [details]
Toshiba 1555 Satellite config
Comment 7 Paul Tibbitts 2003-08-28 12:57:05 EDT
Created attachment 94042 [details]
result of termination of x server on toshiba 1555
Comment 8 Mike A. Harris 2004-10-01 02:19:28 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.


Note You need to log in before you can comment on or make changes to this bug.