Bug 1030308 - when the app gear dir is missing, after deleting the app, the app's httpd config info is still in '.httpd.d/nodes.txt'
when the app gear dir is missing, after deleting the app, the app's httpd con...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lokesh Mandvekar
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 05:32 EST by Cong Wei
Modified: 2015-05-14 19:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-26 14:08:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cong Wei 2013-11-14 05:32:26 EST
Description of problem:
 
when the app gear dir is missing, after destroy the gear, the app's httpd config still in 'nodes.txt'

Version-Release number of selected component (if applicable):

devenv_4031

How reproducible:
always

Steps to Reproduce:
1.Create an app
  rhc create-app app1 php 

2.Ssh instance, go to /var/lib/openshift, only remove the app dir

3. Destroy this app
  rhc delete-app app1

4. try to delete the http config using "oo-devel-node frontend-destroy"
[root@ip-10-100-215-134 openshift]# oo-devel-node frontend-destroy -c 52849c85eaf50c5dda000007

Actual results:
The app's httpd config still in .httpd.d/node.db.

when run:oo-devel-node frontend-destroy --with-container-uuid 52849c85eaf50c5dda000007
  show: 52849c85eaf50c5dda000007 is missing or not a valid gear: OPENSHIFT_APP_UUID is missing!

Expected results:
Should be able to remove the frontend config files by destroy gear when the gear home dir is missing.

Additional info:
Comment 1 Ben Parees 2013-11-21 11:36:13 EST
this fails because the .env directory for the app was removed which means the app information cannot be looked up during the frontend-destroy flow.  Will need to determine if this information (app uuid, app name, gear name) can be retrieved in another way.
Comment 3 Lokesh Mandvekar 2014-02-11 17:14:04 EST
(In reply to Cong Wei from comment #0)
> Description of problem:
>  
> when the app gear dir is missing, after destroy the gear, the app's httpd
> config still in 'nodes.txt'
> 
> Version-Release number of selected component (if applicable):
> 
> devenv_4031
> 
> How reproducible:
> always
> 
> Steps to Reproduce:
> 1.Create an app
>   rhc create-app app1 php 
> 
> 2.Ssh instance, go to /var/lib/openshift, only remove the app dir
> 
> 3. Destroy this app
>   rhc delete-app app1
> 
After this step,
"oo-admin-gear -a destroygear -u $uuid" should purge things
Comment 4 Meng Bo 2014-02-12 00:54:16 EST
oo-admin-gear -a destroygear can delete the gear's remaining files on node.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.