Bug 1030318 - xine channels.conf location moved
xine channels.conf location moved
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xine-lib (Show other bugs)
20
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 05:51 EST by Paul Finnigan
Modified: 2013-11-14 15:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-14 15:17:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 702580 None None None Never

  None (edit)
Description Paul Finnigan 2013-11-14 05:51:46 EST
Description of problem:

When selecting DVB fromn the UI in xine I get the message "No valid channels.conf found" and the UI locks up, it needs to be killed. Confusing as I had one that looked correct in ~/.xine/

I have found that you need to put the channels.conf file into ~/.config/xine-lib/

This is a problem that needs to be passed upstream I would think. Debian has a similar problem reorted (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=702580) but this is for a different version of xine-lib

It is not a major issue. Just people need to be aware of the location that channels.conf should be placed.

Version-Release number of selected component (if applicable):
1.2.4-3.fc20

How reproducible:
Every time

Steps to Reproduce:
1. Put channels.conf in ~/.xine/
2. Start xine
3. Select DVB

Actual results:
UI unusable

Expected results:
Watch TV

Additional info:
Move channels.conf file to ~/.config/xine-lib/channels.conf and everything works as expected
Comment 1 Rex Dieter 2013-11-14 07:53:27 EST
xine-lib is no longer in fedora, please report to bugzilla.rpmfusion.org instead.
Comment 2 Kevin Kofler 2013-11-14 15:17:05 EST
That, plus I'm sure this is an intentional change (following modern-day freedesktop.org specifications rather than legacy Unix conventions), not a bug at all. 1.2 is a major new version, there are years of development between 1.1 and 1.2.

Note You need to log in before you can comment on or make changes to this bug.