Bug 1030398 - Horizon in RHOS directs the user to upstream documentation
Horizon in RHOS directs the user to upstream documentation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Linux
high Severity high
: rc
: 4.0
Assigned To: Francesco Vollero
Lon Hohberger
: OtherQA, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 06:17 EST by Matthias Runge
Modified: 2016-04-26 15:37 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Known Issue
Doc Text:
Cause: The links in Horizon point to upstream documentation not published by Red Hat. Consequence: Users may perform actions based on incorrect documentation. Workaround (if any): Visit access.redhat.com for RHEL OpenStack Platform documentation directly. Result: Correct documentation is available.
Story Points: ---
Clone Of: 1015869
Environment:
Last Closed: 2013-12-19 19:35:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 60009 None None None Never
OpenStack gerrit 60196 None None None Never

  None (edit)
Comment 4 Alvaro Lopez Ortega 2013-11-15 08:35:44 EST
The issue seems to be in the Horizon's Puppet module.
Comment 7 Julie Pichon 2013-12-04 11:30:31 EST
Summer Long from the documentation team gave us the https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/4/index.html URL, and indicated it's not live yet. This is the same link we're now using in the horizon package, I think we should proceed with it. Thanks!
Comment 9 Scott Lewis 2013-12-09 10:30:44 EST
Adding OtherQA for bugs in MODIFIED
Comment 11 Lon Hohberger 2013-12-11 16:25:03 EST
From /etc/openstack-dashboard/local_settings:

https://access.redhat.com/site/documentation//en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/4/index.html

...returns 404 as expected.  There's an extra / - but I verified that this works with:

https://access.redhat.com/site/documentation//en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/3/index.html

on version: openstack-packstack-2013.2.1-0.18.dev934.el6ost.noarch
Comment 13 errata-xmlrpc 2013-12-19 19:35:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.