Bug 1030402 - mount.ceph helper in wrong directory
mount.ceph helper in wrong directory
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: ceph (Show other bugs)
el6
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Boris Ranto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 06:22 EST by Rolf Fokkens
Modified: 2014-10-09 15:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: ceph-0.80.5-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-09 15:51:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Fokkens 2013-11-14 06:22:21 EST
Description of problem:
After having installed ceph the mount command should invoke the mount.ceph helper when mount "-t ceph", but the helper is not invoked. This is caused by the fact that mount.ceph is in /usr/sbin while mount searches /sbin


Version-Release number of selected component (if applicable):
ceph-0.67.3-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. install the ceph package
2. mount -t ceph with the secretfile= option
3. note that the helper is not called resulting in the kernel not understanding the secretfile= option

Actual results:
mount: wrong fs type, bad option, bad superblock on 195.169.23.142:/,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
syslog:
libceph: bad option at 'secretfile=/etc/ceph/secret.admin.key'

Expected results:
succesful mount

Additional info:
Is probably caused by the fact that (recent) fedora moved /sbin to /usr/sbin, but the src.rpm should make an exception for epel.
Comment 1 Rolf Fokkens 2013-11-29 06:59:06 EST
Suggested change to the spec file:

--- ceph.spec	2013-10-07 12:32:06.000000000 +0200
+++ ceph.spec.new	2013-11-29 12:58:04.025010417 +0100
@@ -104,6 +104,10 @@
 
 %install
 make install DESTDIR=$RPM_BUILD_ROOT
+%if 0%{?rhel} >= 6
+mkdir $RPM_BUILD_ROOT/sbin
+mv $RPM_BUILD_ROOT/%{_sbindir}/mount.ceph $RPM_BUILD_ROOT/sbin/mount.ceph
+%endif
 find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
 find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
 install -D src/init-ceph $RPM_BUILD_ROOT%{_initrddir}/ceph
@@ -164,7 +168,11 @@
 %{_bindir}/ceph-rest-api
 %{_initrddir}/ceph
 %{_sbindir}/mkcephfs
+%if 0%{?rhel} >= 6
+/sbin/mount.ceph
+%else
 %{_sbindir}/mount.ceph
+%endif
 %{_sbindir}/ceph-disk-activate
 %{_sbindir}/ceph-disk-prepare
 %{_sbindir}/ceph-create-keys
Comment 2 Rolf Fokkens 2014-07-22 09:37:35 EDT
july 2014, 8 months later: same bug.

ceph-0.80.1-2.el6.x86_64

Please apply the fix in comment #1.
Comment 3 Fedora Update System 2014-08-17 12:18:05 EDT
ceph-0.80.5-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ceph-0.80.5-6.el6
Comment 4 Fedora Update System 2014-08-18 14:58:17 EDT
Package ceph-0.80.5-6.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ceph-0.80.5-6.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2240/ceph-0.80.5-6.el6
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-08-22 15:16:06 EDT
Package ceph-0.80.5-8.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ceph-0.80.5-8.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2240/ceph-0.80.5-8.el6
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-09-06 16:29:42 EDT
Package ceph-0.80.5-9.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ceph-0.80.5-9.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2240/ceph-0.80.5-9.el6
then log in and leave karma (feedback).
Comment 7 Rolf Fokkens 2014-10-04 02:54:51 EDT
The forementioned ceph-0.80.5-9 solves the problem, but the current version is broken (again?):

[root@thdev2 ~]# rpm -q ceph
ceph-0.81.0-5.el6.x86_64
[root@thdev2 ~]# rpm -q -l ceph | grep mount
/usr/sbin/mount.ceph
/usr/share/man/man8/mount.ceph.8.gz
[root@thdev2 ~]#
Comment 8 Boris Ranto 2014-10-04 03:22:56 EDT
Hi Rolf,

the version 1:ceph-0.80.5-9 supersedes the version ceph-0.81.0-5.el6.x86_64 which is just a development/testing version of the ceph package. The package in fedora or epel won't ever be pushed to that version (it will always be pushed to the latest stable version).

i.e. the version 0:ceph-0.81.0-5.el6.x86_64 is broken but the version 1:ceph-0.80.5-9 is an upgrade for it and fixes the problem -> moving back to ON_QA.
Comment 9 Rolf Fokkens 2014-10-04 05:02:10 EDT
Oops, you'r right. Overlooked that there's an epoch involved.
Comment 10 Boris Ranto 2014-10-06 10:26:07 EDT
Yep, we had to involve epochs because the version 0.81 should have never landed in fedora/epel -- it is unstable development version of the ceph project.
Comment 11 Fedora Update System 2014-10-09 15:51:47 EDT
ceph-0.80.5-9.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.