This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1030408 - Leaking timerfds when we fall back to polling the ccache
Leaking timerfds when we fall back to polling the ccache
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
: 1022244 1029653 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 06:34 EST by Harald Hoyer
Modified: 2014-04-09 11:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-09 11:10:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 711696 None None None Never

  None (edit)
Description Harald Hoyer 2013-11-14 06:34:33 EST
gnome-online-accounts-3.10.1-2.fc20.x86_64

#0  0x0000003f254504a9 in g_logv (log_domain=0x3f254b2f0e "GLib", log_level=G_LOG_LEVEL_ERROR, format=<optimized out>, args=args@entry=0x7f0949571850)
    at gmessages.c:989
989			G_BREAKPOINT ();

#0  0x0000003f254504a9 in g_logv (log_domain=0x3f254b2f0e "GLib", log_level=G_LOG_LEVEL_ERROR, format=<optimized out>, args=args@entry=0x7f0949571850)
    at gmessages.c:989
#1  0x0000003f254505ff in g_log (log_domain=log_domain@entry=0x3f254b2f0e "GLib", log_level=log_level@entry=G_LOG_LEVEL_ERROR, 
    format=format@entry=0x3f25505dc0 "Creating pipes for GWakeup: %s\n") at gmessages.c:1025
#2  0x0000003f25489722 in g_wakeup_new () at gwakeup.c:163
#3  0x0000003f25446eea in g_main_context_new () at gmain.c:615
#4  0x0000003f264cdb72 in initable_init (initable=0x7f09304af5d0, cancellable=0x0, error=0x7f0949571ba0) at gdbusproxy.c:1981
#5  0x0000003f26459bca in g_initable_new_valist (object_type=<optimized out>, first_property_name=first_property_name@entry=0x3f265191f3 "g-flags", 
    var_args=var_args@entry=0x7f09495719f0, cancellable=cancellable@entry=0x0, error=error@entry=0x7f0949571ba0) at ginitable.c:231
#6  0x0000003f26459cb9 in g_initable_new (object_type=<optimized out>, cancellable=cancellable@entry=0x0, error=error@entry=0x7f0949571ba0, 
    first_property_name=first_property_name@entry=0x3f265191f3 "g-flags") at ginitable.c:149
#7  0x0000003f264cf2d9 in g_dbus_proxy_new_sync (connection=0x2233050, flags=G_DBUS_PROXY_FLAGS_DO_NOT_LOAD_PROPERTIES, info=info@entry=0x0, 
    name=0x7f09343b4470 "org.gnome.Identity", object_path=0x7f09343b4450 "/org/gnome/Identity", 
    interface_name=interface_name@entry=0x3f2651cc58 "org.freedesktop.DBus.ObjectManager", cancellable=cancellable@entry=0x0, 
    error=error@entry=0x7f0949571ba0) at gdbusproxy.c:2170
#8  0x0000003f264dc684 in initable_init (initable=0x7f09343b5a50, cancellable=0x0, error=0x7f0949571ba0) at gdbusobjectmanagerclient.c:1336
#9  0x0000003f264331ee in async_init_thread (task=0x2234510, source_object=<optimized out>, task_data=<optimized out>, cancellable=<optimized out>)
    at gasyncinitable.c:260
#10 0x0000003f2647c805 in g_task_thread_pool_thread (thread_data=0x2234510, pool_data=<optimized out>) at gtask.c:1245
#11 0x0000003f2546f3c6 in g_thread_pool_thread_proxy (data=<optimized out>) at gthreadpool.c:309
#12 0x0000003f2546ea05 in g_thread_proxy (data=0x7f09401bca30) at gthread.c:798
#13 0x00000032b1207f33 in start_thread (arg=0x7f0949572700) at pthread_create.c:309
#14 0x00000032b06f4ead in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111
(gdb) up
#1  0x0000003f254505ff in g_log (log_domain=log_domain@entry=0x3f254b2f0e "GLib", log_level=log_level@entry=G_LOG_LEVEL_ERROR, 
    format=format@entry=0x3f25505dc0 "Creating pipes for GWakeup: %s\n") at gmessages.c:1025
1025	  g_logv (log_domain, log_level, format, args);
(gdb) up
#2  0x0000003f25489722 in g_wakeup_new () at gwakeup.c:163
163	    g_error ("Creating pipes for GWakeup: %s\n", error->message);
(gdb) print error->message
$1 = (gchar *) 0x7f09304b9220 "Too many open files"
(gdb) up
#3  0x0000003f25446eea in g_main_context_new () at gmain.c:615
615	  context->wakeup = g_wakeup_new ();
(gdb) up
#4  0x0000003f264cdb72 in initable_init (initable=0x7f09304af5d0, cancellable=0x0, error=0x7f0949571ba0) at gdbusproxy.c:1981
1981	  data->context = g_main_context_new ();
(gdb) up
#5  0x0000003f26459bca in g_initable_new_valist (object_type=<optimized out>, first_property_name=first_property_name@entry=0x3f265191f3 "g-flags", 
    var_args=var_args@entry=0x7f09495719f0, cancellable=cancellable@entry=0x0, error=error@entry=0x7f0949571ba0) at ginitable.c:231
231	  if (!g_initable_init (G_INITABLE (obj), cancellable, error))
(gdb) up
#6  0x0000003f26459cb9 in g_initable_new (object_type=<optimized out>, cancellable=cancellable@entry=0x0, error=error@entry=0x7f0949571ba0, 
    first_property_name=first_property_name@entry=0x3f265191f3 "g-flags") at ginitable.c:149
149	  object = g_initable_new_valist (object_type,
(gdb) up
#7  0x0000003f264cf2d9 in g_dbus_proxy_new_sync (connection=0x2233050, flags=G_DBUS_PROXY_FLAGS_DO_NOT_LOAD_PROPERTIES, info=info@entry=0x0, 
    name=0x7f09343b4470 "org.gnome.Identity", object_path=0x7f09343b4450 "/org/gnome/Identity", 
    interface_name=interface_name@entry=0x3f2651cc58 "org.freedesktop.DBus.ObjectManager", cancellable=cancellable@entry=0x0, 
    error=error@entry=0x7f0949571ba0) at gdbusproxy.c:2170
2170	  initable = g_initable_new (G_TYPE_DBUS_PROXY,
(gdb) up
#8  0x0000003f264dc684 in initable_init (initable=0x7f09343b5a50, cancellable=0x0, error=0x7f0949571ba0) at gdbusobjectmanagerclient.c:1336
1336	  manager->priv->control_proxy = g_dbus_proxy_new_sync (manager->priv->connection,
(gdb) up
#9  0x0000003f264331ee in async_init_thread (task=0x2234510, source_object=<optimized out>, task_data=<optimized out>, cancellable=<optimized out>)
    at gasyncinitable.c:260
260	  if (g_initable_init (G_INITABLE (source_object), cancellable, &error))
(gdb) quit
Comment 1 Debarshi Ray 2013-11-14 07:09:25 EST
Should be fixed in gnome-online-accounts-3.10.2-1.fc20 which will be part of the GNOME 3.10.2 mega update.
Comment 2 Debarshi Ray 2013-11-14 07:14:55 EST
*** Bug 1022244 has been marked as a duplicate of this bug. ***
Comment 3 Debarshi Ray 2013-11-14 07:17:19 EST
*** Bug 1029653 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.