Bug 1030456 - Remove -as from hard-coded application names in ejb-asyncrhonous and a few other quickstarts
Remove -as from hard-coded application names in ejb-asyncrhonous and a few ot...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: DR1
: EAP 6.3.0
Assigned To: sgilda
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 08:43 EST by sgilda
Modified: 2014-10-25 08:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 10:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sgilda 2013-11-14 08:43:40 EST
Description of problem:

I found a few more instances where I missed the jboss-as-*.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 sgilda 2013-11-14 09:07:21 EST
Fixed ejb-asynchronous, but after the tests successfully complete, I see this in the log:

ERROR [org.jboss.as.ejb3] (EJB default - 1) JBAS014249: Error invoking method public abstract void org.jboss.as.quickstarts.ejb.asynchronous.AsynchronousAccess.fireAndForget(long) on bean named AsynchronousAccessBean for appname  modulename jboss-ejb-asynchronous-ejb distinctname : java.lang.NullPointerException
	at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler.invokeMethod(MethodInvocationMessageHandler.java:322)
	at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler.access$100(MethodInvocationMessageHandler.java:70)
	at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler$1.run(MethodInvocationMessageHandler.java:203)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_09]
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_09]
	at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_09]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_09]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_09]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_09]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.1.Final-redhat-1.jar:2.1.1.Final-redhat-1]

08:46:12,776 ERROR [org.jboss.as.ejb3] (EJB default - 1) JBAS014250: Could not write method invocation failure for method public abstract void org.jboss.as.quickstarts.ejb.asynchronous.AsynchronousAccess.fireAndForget(long) on bean named AsynchronousAccessBean for appname  modulename jboss-ejb-asynchronous-ejb distinctname  due to: java.io.IOException: JBAS014560: Could not open message outputstream for writing to Channel
	at org.jboss.as.ejb3.remote.protocol.AbstractMessageHandler.writeException(AbstractMessageHandler.java:102)
	at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler.access$400(MethodInvocationMessageHandler.java:70)
	at org.jboss.as.ejb3.remote.protocol.versionone.MethodInvocationMessageHandler$1.run(MethodInvocationMessageHandler.java:213)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_09]
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_09]
	at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_09]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_09]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_09]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_09]
	at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads-2.1.1.Final-redhat-1.jar:2.1.1.Final-redhat-1]
Caused by: org.jboss.remoting3.NotOpenException: Writes closed
	at org.jboss.remoting3.remote.RemoteConnectionChannel.openOutboundMessage(RemoteConnectionChannel.java:108) [jboss-remoting-3.2.17.GA-redhat-1.jar:3.2.17.GA-redhat-1]
	at org.jboss.remoting3.remote.RemoteConnectionChannel.writeMessage(RemoteConnectionChannel.java:297) [jboss-remoting-3.2.17.GA-redhat-1.jar:3.2.17.GA-redhat-1]
	at org.jboss.as.ejb3.remote.protocol.versionone.ChannelAssociation.acquireChannelMessageOutputStream(ChannelAssociation.java:68)
	at org.jboss.as.ejb3.remote.protocol.AbstractMessageHandler.writeException(AbstractMessageHandler.java:100)
	... 9 more
Comment 2 sgilda 2013-11-14 09:08:33 EST
fixed with this commit:

https://github.com/jboss-developer/jboss-eap-quickstarts/commit/aca5f864670fd7ad2211fa3f20f599e27ef5f7e0

I will open a new bug for the above stacktrace.
Comment 3 Nikoleta Ziakova 2013-11-21 09:39:58 EST
(1) I have found some more "-as" in application names (only in descriptions, not source code):

./logging-tools/src/main/webapp/index.html
    <head><title>jboss-as-logging-tools Quick Start</title></head>

./helloworld-mdb/cheatsheets/helloworld-mdb.xml
    <b>http://localhost:8080//jboss-as-helloworld-mdb/HelloWorldMDBServletClient</b>
    param1="jboss-as-helloworld-mdb"


(2) These are not names of applications but the path to these classes is inorrect due to the name of the quickstart -- its name is "helloworld-mdb" instead of "jboss-as-helloworld-mdb":
./helloworld-mdb/cheatsheets/helloworld-mdb.xml
    param1="/jboss-as-helloworld-mdb/src/main/java/org/jboss/as/quickstarts/servlet/HelloWorldMDBServletClient.java"
    param1="/jboss-as-helloworld-mdb/src/main/java/org/jboss/as/quickstarts/mdb/HelloWorldQueueMDB.java"
    param1="/jboss-as-helloworld-mdb/src/main/java/org/jboss/as/quickstarts/mdb/HelloWorldTopicMDB.java"


(3) Incorrect artifact id mentioned:
./CONTRIBUTING.md: the `<artifactId>` for the `greeter` quickstart in the EAP project is `jboss-as-greeter`
pom.xml in greeter qs says: <artifactId>jboss-greeter</artifactId>
Comment 5 Nikoleta Ziakova 2013-11-22 04:13:31 EST
This issue is not fixed in CR3. CR3 build does not contain commit from comment #4.
Comment 6 sgilda 2013-11-22 09:48:47 EST
Apparently it did not make the CR3 build. Set to pending.
Comment 7 sgilda 2014-02-27 16:04:58 EST
This should be fixed in the current 6.3 builds
Comment 8 Nikoleta Ziakova 2014-03-04 05:03:07 EST
Verified with EAP 6.3.0 DR1

Note You need to log in before you can comment on or make changes to this bug.