Bug 1030466 - [engine-dwh] ovirt-engine-dwh-setup should stored values provided in interactive setup in the answer file
[engine-dwh] ovirt-engine-dwh-setup should stored values provided in interact...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.4.0
Assigned To: Sandro Bonazzola
Barak Dagan
integration
:
Depends On: 1058012
Blocks: 1025336 rhev3.4beta 1142926
  Show dependency treegraph
 
Reported: 2013-11-14 09:03 EST by Barak Dagan
Modified: 2014-09-18 08:24 EDT (History)
9 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
The engine-setup command now automatically generates answer files for configuration of the data warehouse based on the values entered during interactive setup.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-09 11:16:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0601 normal SHIPPED_LIVE rhevm-dwh 3.4 bug fix and enhancement update 2014-06-09 15:15:53 EDT

  None (edit)
Description Barak Dagan 2013-11-14 09:03:30 EST
Description of problem:

1) The values in the answer file are all none instead of the values entered in the installation. There is not much point of making the user edit and the file and figure out which value should be used.

If I understand correctly, STOP_ENGINE=No will break the installation - so why giving that option ?

was checked over 2 setups, clean installation + update, before and after dwh installation

# rhevm-dwh-setup --gen-answer-file=a1
Answer file generated at a1

# cat a1
[general]
REMOTE_DB_PORT=None
CREATE_READONLY_USER=None
STOP_ENGINE=None
REMOTE_DB_HOST=None
READONLY_SECURE=None
REMOTE_DB_PASSWORD=None
REMOTE_DB_USER=None
READONLY_USER=None
BACKUP_DB=None
READONLY_PASS=None


2) coukd be nice if the answer file would be generated automatically like in the engine setup

Version-Release number of selected component (if applicable):
is23

How reproducible:
100%

Steps to Reproduce:
1. install engine + dwh
2. run the command rhevm-dwh-setup -g=answerfile
3. 

Actual results:
useless answer file and no auto generated one

Expected results:
answer file containing entered answers, relevant keys and no auto generated one

Additional info:
Comment 1 Sandro Bonazzola 2013-11-14 10:14:59 EST
Since the answer file handling was added for QA automation I think we can postpone this to 3.4 when the migration to otopi will join engine-setup answerfile and dwh answer file in the same one.
Comment 2 Alex Lourie 2013-11-14 11:08:05 EST
@Barak

I think you misinterpreting the purpose of the answer file. The *sole* purpose of the generated answerfile is to provide you with the possible options that can be set in it. Then you would you this file to perform an unattended installation.

The dwh/reports setup do not touch the answerfile after it's created.

So I don't think this bug is valid.
Comment 3 Barak Dagan 2013-11-14 11:21:29 EST
@Alex

I don't see anywhere that the dwh/reports setup touched the answer file, on the contrary, I'd expect it to recreate one during the installation - as the engine setup does.

Second, I don't understand what is the point of manually generating list of options with none values. Such a file can be packed in the beginning. When a user Performs an action after the installation, he might expect that his values will be generated as well - like the new engine setup does.

If this is too complicated to be done in the current version, you can accept Sandro's suggestion to delay it to the next one.
Comment 4 Alex Lourie 2013-11-17 09:32:24 EST
@Sandro

This bug is a check point for implementing post-install answer file in dwh/reports with otopi.
Comment 7 Barak Dagan 2014-03-05 08:18:35 EST
Verified on av2

rhevm-dwh-3.4.0-0.4.master.20140224152332.el6ev.noarch
rhevm-dwh-setup-3.4.0-0.4.master.20140224152332.el6ev.noarch

rhevm-reports-3.4.0-0.4.master.20140226133324.el6ev.noarch
rhevm-reports-setup-3.4.0-0.4.master.20140226133324.el6ev.noarch


jasperreports-server-pro-5.5.0-7.el6ev.noarch
Comment 8 errata-xmlrpc 2014-06-09 11:16:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0601.html

Note You need to log in before you can comment on or make changes to this bug.