Bug 103048 - strange errors when including xmmintrin.h
Summary: strange errors when including xmmintrin.h
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-25 20:44 UTC by Pierre-Olivier Gaillard
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-29 17:29:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pierre-Olivier Gaillard 2003-08-25 20:44:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
Gcc 3.2 is supposed to support Intel SSE2 intrinsics. But when I try to include
the xmmintrin.h, I get error messages saying that the sizes are incompatible.
NOTE : this is different from the errors you get when you forget to use the
-msse2 flag.

Version-Release number of selected component (if applicable):
gcc-3.2.2

How reproducible:
Always

Steps to Reproduce:
1. create a simple program including xmmintrin.h
2. compile the program with gcc -msse2 my_prog.c

    

Actual Results:  Many errors like the following are displayed.
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/include/xmmintrin.h: In function
`_mm_add_ss':
/usr/lib/gcc-lib/i386-redhat-linux/3.2.2/include/xmmintrin.h:90: can't convert
between vector values of different size


Expected Results:  The program should compile and no error should be displayed,
since the xmmintrin.h and the gcc binary are both from gcc 3.2.2 (I checked the
gcc version with gcc --version).


Additional info:

Note that the mmintrin.h is correct and works ok with the -msse2 flag set.

Comment 1 Jakub Jelinek 2003-08-29 17:29:30 UTC
No, only gcc 3.3 and later are supposed to handle SSE2 intrinsics fully (gcc 3.2.x should
handle SSE).


Note You need to log in before you can comment on or make changes to this bug.