This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1030490 - bad fat32 SD card leaves fstab mount entry
bad fat32 SD card leaves fstab mount entry
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 09:40 EST by Brent R Brian
Modified: 2014-06-19 20:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-19 20:10:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot log that mentions fstab entry (9.72 KB, text/x-log)
2013-11-14 09:40 EST, Brent R Brian
no flags Details
messages file with boot that "hung" and boot that passed (257.63 KB, text/plain)
2013-11-14 10:30 EST, Brent R Brian
no flags Details

  None (edit)
Description Brent R Brian 2013-11-14 09:40:01 EST
Created attachment 823992 [details]
boot log that mentions fstab entry

Working with bad SD card to recover data.  

F19 system had trouble mounting.  

When mount succeeded, it left an entry in fstab that was not removed.

#
# /etc/fstab
# Created by anaconda on Fri Jan 18 11:58:25 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=7d24087c-db36-4c63-8f77-d9aa33be7454 /                       ext3    defaults        1 1
UUID=f04c2e62-b858-46b3-b180-369b6ce762a9 /home                   ext3    defaults        1 2
UUID=9fc0ed5f-26e3-44c3-8a7a-036d97831a4b swap                    swap    defaults        0 0
/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0 /mnt/usb-Generic-_Multi-Card_20071114173400000-0:0 auto ro
,nosuid,nodev,nofail,x-gvfs-show 0 0

Booting after this has stopped, CTRL-ALT-DEL did not work, had to power off.

Removed entry by hand.
Comment 1 Brent R Brian 2013-11-14 10:30:07 EST
Created attachment 824005 [details]
messages file with boot that "hung" and boot that passed

First boot hung (reset with power button).

Second boot worked.
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-11-17 16:33:23 EST
Looks like another version of https://bugzilla.redhat.com/show_bug.cgi?id=1006386...
Comment 3 Brent R Brian 2014-02-04 09:45:56 EST
Have not seen problem on F20
Comment 4 Lennart Poettering 2014-06-19 20:10:00 EDT
OK, closing then.

Note You need to log in before you can comment on or make changes to this bug.