Bug 1030494 - openstack-keystone failed dependencies in centos6.4: sqlalchemy, webob, python-paste-deploy, python-routes
openstack-keystone failed dependencies in centos6.4: sqlalchemy, webob, pytho...
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-keystone (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Ami Jeain
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 09:51 EST by wes hayutin
Modified: 2016-04-26 13:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 09:54:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packstack logs (5.26 MB, application/octet-stream)
2013-11-21 16:28 EST, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2013-11-14 09:51:57 EST
Description of problem:

python-sqlalchemy0.7 is not available in centos, python-sqlalchemy-0.5.5-3.el6_2.noarch.rpm is the package in centos.

http://www.gtlib.gatech.edu/pub/centos/6.4/os/x86_64/Packages/

It does appear that python-sqlalchemy0.7 was available for centos on Nov 7, 2013, but is no longer available.


[root@centos64 yum.repos.d]# cat /etc/redhat-release 
CentOS release 6.4 (Final)
[root@centos64 yum.repos.d]# rpm -q rdo-release
rdo-release-havana-7.noarch
[root@centos64 yum.repos.d]# ll
total 28
-rw-r--r--. 1 root root 1926 Feb 25  2013 CentOS-Base.repo
-rw-r--r--. 1 root root  638 Feb 25  2013 CentOS-Debuginfo.repo
-rw-r--r--. 1 root root  630 Feb 25  2013 CentOS-Media.repo
-rw-r--r--. 1 root root 3664 Feb 25  2013 CentOS-Vault.repo
-rw-r--r--. 1 root root  713 Nov 14 09:24 foreman.repo
-rw-r--r--. 1 root root 1250 Nov 14 09:24 puppetlabs.repo
-rw-r--r--. 1 root root  240 Nov 14 09:24 rdo-release.repo
[root@centos64 yum.repos.d]# yum repolist
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: ftpmirror.your.org
 * extras: mirror.fdcservers.net
 * updates: mirrors.seas.harvard.edu
repo id                                        repo name                                                          status
base                                           CentOS-6 - Base                                                    6,381
extras                                         CentOS-6 - Extras                                                     13
foreman                                        Foreman stable                                                       198
foreman-plugins                                Foreman stable - plugins                                              40
openstack-havana                               OpenStack Havana Repository                                          516
puppetlabs-deps                                Puppet Labs Dependencies El 6 - x86_64                                54
puppetlabs-products                            Puppet Labs Products El 6 - x86_64                                   304
updates                                        CentOS-6 - Updates                                                 1,538
repolist: 9,044
[root@centos64 yum.repos.d]# yum -d 0 -e 0 -y install openstack-keystone
Error: Package: python-keystone-2013.2-1.el6.noarch (openstack-havana)
           Requires: python-sqlalchemy0.7
Error: Package: python-keystone-2013.2-1.el6.noarch (openstack-havana)
           Requires: python-routes1.12
Error: Package: python-keystone-2013.2-1.el6.noarch (openstack-havana)
           Requires: python-paste-deploy1.5
Error: Package: python-migrate-0.7.2-8.el6.noarch (openstack-havana)
           Requires: python-sqlalchemy0.7
Error: Package: python-oauth2-1.5.211-5.el6.noarch (openstack-havana)
           Requires: python-httplib2
Error: Package: 1:python-keystoneclient-0.4.1-3.el6.noarch (openstack-havana)
           Requires: python-keyring
Error: Package: python-keystone-2013.2-1.el6.noarch (openstack-havana)
           Requires: python-six
Error: Package: 1:python-keystoneclient-0.4.1-3.el6.noarch (openstack-havana)
           Requires: python-prettytable
Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana)
           Requires: python-argparse
Error: Package: python-dogpile-cache-0.5.0-1.el6.noarch (openstack-havana)
           Requires: python-dogpile-core >= 0.4.1
Error: Package: python-keystone-2013.2-1.el6.noarch (openstack-havana)
           Requires: python-passlib
Error: Package: 1:python-keystoneclient-0.4.1-3.el6.noarch (openstack-havana)
           Requires: python-requests >= 0.8.8
Error: Package: 1:python-keystoneclient-0.4.1-3.el6.noarch (openstack-havana)
           Requires: python-six
Error: Package: python-keystone-2013.2-1.el6.noarch (openstack-havana)
           Requires: python-eventlet
Error: Package: 1:python-keystoneclient-0.4.1-3.el6.noarch (openstack-havana)
           Requires: python-argparse
Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana)
           Requires: python-six
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@centos64 yum.repos.d]#
Comment 1 wes hayutin 2013-11-14 09:54:35 EST
The issue may apply to..

# These are required to build due to the requirements check added
BuildRequires:  python-sqlalchemy0.7
BuildRequires:  python-webob1.2
BuildRequires:  python-paste-deploy1.5
BuildRequires:  python-routes1.12
Comment 2 Pádraig Brady 2013-11-14 13:50:24 EST
These packages are in epel.

Perhaps packstack is not enabling epel automatically on centos?
Comment 3 Alan Pevec 2013-11-18 15:34:14 EST
EPEL is required for RDO EL6
Comment 4 wes hayutin 2013-11-21 16:28:22 EST
Created attachment 827457 [details]
packstack logs

packstack logs, check the packstack config and you can see epel is enabled.
So we'll have to track down why the epel repo is not installed/configured.

reopening
Comment 5 wes hayutin 2013-11-25 09:54:19 EST
issue w/ our base image re-closing.

Note You need to log in before you can comment on or make changes to this bug.