Bug 1030502 - unable to connect rhsc-shell to a single label domain
unable to connect rhsc-shell to a single label domain
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-cli (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Shubhendu Tripathi
Dustin Tsang
Corbett
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 10:15 EST by Dustin Tsang
Modified: 2015-07-13 00:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 08:48:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of rhsc-shell connect (25.84 KB, image/png)
2013-12-03 23:19 EST, Shubhendu Tripathi
no flags Details
screenshot (24.89 KB, image/png)
2013-12-05 08:53 EST, Dustin Tsang
no flags Details

  None (edit)
Description Dustin Tsang 2013-11-14 10:15:00 EST
Description of problem:

Using the shell to connect to a single label domain fails. For example connecting using the command below fails.

connect --url 'https://latest:443/api' --user 'admin@internal' --password 'redhat' -I

The following error is obtained. Note that the url format matches.

error: "https://latest:443/api" is invalid url format. valid format is http[s]://server:port/api.



Version-Release number of selected component (if applicable):
rhsc-cb7

How reproducible:
every time

Steps to Reproduce:
1. on the shell session for the machine hosting rhsc, enter command
connect --url 'https://latest:443/api' --user 'admin@internal' --password 'redhat' -I
2. when prompted for password, enter password and hit enter
3. when prompted, type 'connect' and hit enter

Actual results:
error: "https://latest:443/api" is invalid url format. valid format is http[s]://server:port/api.


Expected results:
user is able to successfully connect

Additional info:
Comment 2 Shubhendu Tripathi 2013-11-22 05:43:07 EST
Hi Dustin,

Can you try the same with cb8? Also the command would be as below -

connect --url 'https://hostname/api' --user 'admin@internal' --password 'redhat' -I.

Note here port no not to be mentioned.
Comment 3 Dustin Tsang 2013-12-03 09:08:48 EST
Still an issue in cb10:

error: "https://latest:443/api" is invalid url format. valid format is http[s]://server:port/api.
Comment 4 Shubhendu Tripathi 2013-12-03 23:19:02 EST
Created attachment 832413 [details]
screenshot of rhsc-shell connect
Comment 5 Shubhendu Tripathi 2013-12-03 23:20:17 EST
Dustin,

I tried the below command in cb10 and it works fine

connect --url 'https://10.70.42.167/api' --user 'admin@internal' --password 'redhat' -I

Screenshot shared for reference.

Request you to share the screenshot, the way you are trying to connect.
Comment 6 Dustin Tsang 2013-12-05 08:47:48 EST
the bug is for a domain that only has a single hop dns lookup...for example:
https://latest/api
https://rhsc/api
https://myrhsc/api
https://thisismyrhsc/api
Comment 7 Dustin Tsang 2013-12-05 08:53:04 EST
Created attachment 833163 [details]
screenshot
Comment 8 Shubhendu Tripathi 2013-12-05 22:44:12 EST
Dustin,

In case of oVirt the domain names like https://latest/api, https://rhsc/api are not supported and so the error.

The domain names should be in the form like a.b.com. It should contain "." character. Its should be FQDN actually.

If you access the same setup using the IP address it would work fine.
Comment 9 Dusmant 2013-12-06 04:00:56 EST
If FQDN format or IP address for host name is used and that works fine, then it's not a bug. Dustin, pls. confirm that.
Comment 10 Dustin Tsang 2013-12-06 08:48:04 EST
FQDN or IP Address work fine.

Note You need to log in before you can comment on or make changes to this bug.