Bug 1030531 - Mouse pointer disappears after changing guest resolution
Mouse pointer disappears after changing guest resolution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
7.0
All Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
: 1064773 (view as bug list)
Depends On:
Blocks: 1116870
  Show dependency treegraph
 
Reported: 2013-11-14 11:08 EST by Milan Barta
Modified: 2015-03-05 08:33 EST (History)
14 users (show)

See Also:
Fixed In Version: xorg-x11-drv-qxl-0.1.1-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1116870 (view as bug list)
Environment:
Last Closed: 2015-03-05 08:33:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Barta 2013-11-14 11:08:32 EST
Description of problem:
After changing screen resolution of the guest by resizing the remote-viewer window (arbitrary resolution change feature), the mouse pointer in the guest becomes invisible.

Version-Release number of selected component (if applicable):
Guest: RHEL7
spice-vdagent-0.14.0-5.el7.x86_64

Host & Client: RHEL7
spice-server-0.12.4-3.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
qemu-kvm-1.5.3-19.el7.x86_64
libvirt-client-1.1.1-12.el7.x86_64

How reproducible:
100 % times

Steps to Reproduce:
1. run RHEL7 VM with spice-vdagent service running
2. resize the remote-viewer window

Actual results:
Guest screen resolution changes and the mouse pointer becomes invisible.

Expected results:
The resolution changes and the mouse pointer stays visible as before.

Additional info:
Restarting the spice-vdagent service helps.
Comment 1 RHEL Product and Program Management 2014-03-22 02:31:56 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Vladimir Benes 2014-08-19 04:17:10 EDT
*** Bug 1064773 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2015-03-05 08:33:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0578.html

Note You need to log in before you can comment on or make changes to this bug.