Bug 1030551 - storage properties don't contain production default values in rhq-server.properties
storage properties don't contain production default values in rhq-server.prop...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Installer, Storage Node (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity urgent
: ER07
: JON 3.2.0
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-11-14 11:43 EST by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:36:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (10.38 KB, text/x-log)
2013-11-20 05:55 EST, Armine Hovsepyan
no flags Details
server-props (150.86 KB, image/png)
2013-11-20 05:56 EST, Armine Hovsepyan
no flags Details
server-properties (136.54 KB, image/png)
2013-11-22 06:55 EST, Armine Hovsepyan
no flags Details
server_and_storage_on_diff_machines (122.74 KB, image/png)
2013-11-22 06:55 EST, Armine Hovsepyan
no flags Details
connection_exception (277.62 KB, image/png)
2013-11-22 07:02 EST, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-11-14 11:43:55 EST
Description of problem:
storage properties don't contain production default values in rhq-server.properties

rhq.storage.cql-port and rhq.storage.gossip-port don't contain production default values (9142 and 7100), which is being set to correct values during the storage installation. While installing server and connecting to remote storage (no local storage installation) leads to server not being able to connect to the remote storage.

Version-Release number of selected component (if applicable):
jon 3.2 er5

How reproducible:
always

Steps to Reproduce:
1. install and start storage on IP1
2. connect server to remote storage by adding rhq.storage.nodes=IP1 in rhq-server.properties 
3. install server on IP2 

Actual results:
10:32:13,041 ERROR [org.rhq.enterprise.server.installer.InstallerServiceImpl] Could not complete storage cluster schema installation: All host(s) tried for query failed (tried: /10.16.23.192 ([/10.16.23.192] Cannot connect)): com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: /10.16.23.192 ([/10.16.23.192] Cannot connect))

Expected results:
server is able to connect to remote storage

Additional info:

Comment From John Sanda:
jsanda> the fact that it took this long to realize it was the wrong port might suggest we should provide some additional error messages to help identify problems like this
<jsanda> in a scenario like this where we fail to connect to storage cluster, it might be good to log message like,
<jsanda> "Make sure storage cluster is running, and that the rhq-storage.nodes and rhq.storage.cql-port properties are configured properly
Comment 1 Heiko W. Rupp 2013-11-15 10:40:29 EST
[16:39:22] <mfoley>	 it will be in the ER6 payload.  jsanda will have it done by noon.  then spinder will turn the magic handle and begin brewing ER6
Comment 2 John Sanda 2013-11-15 11:33:18 EST
The out of box values for rhq.storage.cql-port and rhq.storage.gossip-port are now set to their production defaults, 9142 and 7100 respectively. And if the server installer cannot connect to the storage cluster, an error message like this is logged,

11:18:07,487 ERROR [org.rhq.enterprise.server.installer.InstallerServiceImpl] Failed to connect to the storage cluster. Please check the following:
	1) At least one storage node is running
	2) The rhq.storage.nodes property specifies the correct hostname/address of at least one storage node
	3) The rhq.storage.cql-port property has the correct value


release/jon3.2.x branch commit: 76b8858e
Comment 3 Simeon Pinder 2013-11-19 10:49:10 EST
Moving to ON_QA as available for testing with new brew build.
Comment 4 Armine Hovsepyan 2013-11-20 05:33:00 EST
issue is not fixed in er6 - please get logs and rhq-server.properties screenshot attached
Comment 5 Armine Hovsepyan 2013-11-20 05:55:19 EST
Created attachment 826563 [details]
install.log
Comment 6 Armine Hovsepyan 2013-11-20 05:56:01 EST
Created attachment 826564 [details]
server-props
Comment 8 Simeon Pinder 2013-11-21 23:45:00 EST
Moving to ER07 target milestone and MODIFIED as initially rejected by QE because of bad ER6 build but put into varied states(MODIFIED & ASSIGNED).
Comment 9 Simeon Pinder 2013-11-22 00:01:57 EST
Moving to ON_QA as available to test in ER7 and later brew builds.
Comment 10 Armine Hovsepyan 2013-11-22 06:55:05 EST
Created attachment 827704 [details]
server-properties
Comment 11 Armine Hovsepyan 2013-11-22 06:55:41 EST
Created attachment 827705 [details]
server_and_storage_on_diff_machines
Comment 12 Armine Hovsepyan 2013-11-22 07:02:45 EST
Created attachment 827706 [details]
connection_exception
Comment 13 Armine Hovsepyan 2013-11-22 07:03:27 EST
verified in er7
please get screen-shots attached

Note You need to log in before you can comment on or make changes to this bug.