Bug 1030566 - [RHEVM-SETUP] rhevm-python-sdk and rhevm-cli are not updated to the last builds
[RHEVM-SETUP] rhevm-python-sdk and rhevm-cli are not updated to the last builds
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Eyal Edri
Jiri Belka
integration
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 12:16 EST by Barak Dagan
Modified: 2014-07-13 19:20 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-12 03:42:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barak Dagan 2013-11-14 12:16:54 EST
Description of problem:
CLi and SDK dependencies are not updated:

for example, upgrading from 3.3 older build to latest (is23):
Package rhevm-cli.noarch 0:3.3.0.8-1.el6ev should be updated to rhevm-cli.noarch 0:3.3.0.11-1.el6ev
Package rhevm-sdk-python.noarch 0:3.3.0.17-1.el6ev should be updated to rhevm-sdk-python.noarch 0:3.3.0.19-1.el6ev

from 3.2 to 3.3, SDK is updated, but CLI remains:
Package rhevm-cli.noarch 0:3.2.1.1-1.el6ev should be updated to rhevm-cli.noarch 0:3.3.0.11-1.el6ev

Version-Release number of selected component (if applicable):
IS23

How reproducible:
100%

Steps to Reproduce:
1. upgrade to version is23 fromm previous is or sf version
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Sandro Bonazzola 2013-11-19 02:21:33 EST
AFAIK rhevm-python-sdk and rhevm-cli are not under version locking and may be updated just using yum update.
Comment 2 Alon Bar-Lev 2013-11-19 03:27:03 EST
(In reply to Sandro Bonazzola from comment #1)
> AFAIK rhevm-python-sdk and rhevm-cli are not under version locking and may
> be updated just using yum update.

correct, if these needs to be updated explicitly they should be added into the rhevm33/rhevm32 yum groups.
Comment 3 Sandro Bonazzola 2013-11-25 10:20:13 EST
(In reply to Alon Bar-Lev from comment #2)
> (In reply to Sandro Bonazzola from comment #1)
> > AFAIK rhevm-python-sdk and rhevm-cli are not under version locking and may
> > be updated just using yum update.
> 
> correct, if these needs to be updated explicitly they should be added into
> the rhevm33/rhevm32 yum groups.

So should we move this to distribution and reassign or just close as not a bug?
Comment 5 Sandro Bonazzola 2013-12-05 05:07:56 EST
Eyal, can you take care of adding rhevm-python-sdk and rhevm-cli to rhevmgroup.xml in yum repository?
Comment 6 Alon Bar-Lev 2013-12-05 05:16:05 EST
(In reply to Sandro Bonazzola from comment #5)
> Eyal, can you take care of adding rhevm-python-sdk and rhevm-cli to
> rhevmgroup.xml in yum repository?

I am unsure this is wise as these components should be backward compatible, if we need to pull explicit version due to severe breakage we should update the rhevm spec (as it is the meta package).

Please remember that people that replicate the channel, does not replicate the group, so group is only convenient method not functional method.
Comment 7 Sandro Bonazzola 2013-12-12 03:42:36 EST
Decided to close this as not a bug.
hevm-python-sdk and rhevm-cli are not under version locking and may be updated just using yum update.

Note You need to log in before you can comment on or make changes to this bug.