Bug 1030579 - evolution-data-server floods dns server with google queries
evolution-data-server floods dns server with google queries
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 1154434 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 12:40 EST by hansvon
Modified: 2014-10-24 01:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 14:53:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wireshark screenshot (260.69 KB, image/png)
2013-11-14 12:40 EST, hansvon
no flags Details
backtraces (51.60 KB, application/zip)
2013-11-17 04:19 EST, hansvon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 712392 None None None Never

  None (edit)
Description hansvon 2013-11-14 12:40:45 EST
Created attachment 824082 [details]
wireshark screenshot

Description of problem:

After resuming from suspend, evolution-data-server creates hundreds of google.com dns queries. See the attached wireshark screenshot. Only way I found to stop these queries is to "killall evolution-calendar-factory". If I don't, my dsl router crashes after 20-30 seconds. So it's very annoying.

Note that I don't have google set as an online account (anymore). And I don't have evolution installed. I'm just a gnome shell user.


Version-Release number of selected component (if applicable):
evolution-data-server-3.10.1-1.fc20.x86_64


How reproducible:
It happens after I resume from suspend, but not all the times. After the killall, the problem disappears.

Steps to Reproduce:
1.
2.
3.

Actual results:
Flood of DNS queries making my dsl router crash

Expected results:
One or zero query...

Additional info:
Comment 1 Milan Crha 2013-11-15 14:53:26 EST
Thanks for a bug report. There might left some Google calendar definition in the background, which tries to reconnect to the Google server after resume, and fails for some reason. Could you check all *.source files from
   ~/.config/evolution/sources
and
   ~/.cache/evolution/sources
whose contain string "Calendar" (quotes for clarity only), please? You might find there CalDAV related, probably, or even mentioning Google or your Google email address/login.

Are there any such files? And if so, where are they? I would like help you with the resume issue, by dropping the left-over files. We can continue here with this part, if you wish.

-----------------------------------------------------------------------------

For the flood issue, I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

There would be helpful if you could install debuginfo package for evolution-data-server and grabbed a backtrace of evolution-calendar-factory in the state of flooding the DNS, for better identification in which part it is happening. You can get set of backtraces with this command:
   $ for i in {1..10}; do gdb --batch --ex "t a a bt" \
     -pid=`pidof evolution-calendar-factory` &>bt$i.txt; sleep 0.1; done

Anz zip the 10 files and attach them here. Please make sure you'll not expose any private data, like passwords, email addresses and such, which can be shown in the backtrace (I usually search for "pass" (quotes for clarity only)). Thanks in advance.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=712392
Comment 2 hansvon 2013-11-17 04:19:04 EST
Thank you for your help. I had indeed a "google calendar" source file in .config/evolution/sources/
If I delete it, it seems to be recreated?

I've attached the requested backtraces.
Comment 3 hansvon 2013-11-17 04:19:55 EST
Created attachment 825104 [details]
backtraces
Comment 4 Milan Crha 2013-11-20 06:49:15 EST
(In reply to hansvon from comment #2)
> If I delete it, it seems to be recreated?

That may mean the calendar is configured from outside, like from GNOME Online Accounts. When you open the Online Accounts settings in System settings, is there you Google account? Does it have enabled the Calendar part? I'm currently not aware of any other place from where the Calendar would be recreated "on its own".
Comment 5 Milan Crha 2014-10-23 12:43:41 EDT
*** Bug 1154434 has been marked as a duplicate of this bug. ***
Comment 6 jonc 2014-10-23 14:57:26 EDT
For what it's worth, I noticed that when I set up a Google account with Gnome Online Accounts, it opts to register me in a laundry list of Google services, with no apparent way to pick and choose. I believe that can be done later, via Settings, but I'm sure few actually do that.

When creating a Google account within Evolution, though, I was offered the option of tieing into Google Calendar or not.
Comment 7 Milan Crha 2014-10-24 01:28:51 EDT
(In reply to jonc from comment #6)
> For what it's worth, I noticed that when I set up a Google account with
> Gnome Online Accounts, it opts to register me in a laundry list of Google
> services, with no apparent way to pick and choose. I believe that can be
> done later, via Settings, but I'm sure few actually do that.
> 
> When creating a Google account within Evolution, though, I was offered the
> option of tieing into Google Calendar or not.

Right, both is expected. The list of Google "enabled" services is stored also in the authentication token, which allows you to login to any of them (or disallows with that token, in case of that service not being set there). Once you'll agree on the page you'll get a set of On/Off switches to disable service by service, similar to those in evolution, only many more. GNOME Online Accounts then advertises to other applications what services are offered.

Note You need to log in before you can comment on or make changes to this bug.