Bug 1030580 - Feature request (CLI): Add an option to the CLI to fetch just incremental or cumulative I/O statistics
Feature request (CLI): Add an option to the CLI to fetch just incremental or ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaushal
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 12:41 EST by Dawit Alemu
Modified: 2016-05-05 21:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-11 03:24:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawit Alemu 2013-11-14 12:41:39 EST
Description of problem:
Currently 'volume profile info' fetches both cumulative and incremental I/O statistics. Add an option, to the CLI, to fetch just incremental or cumulative statistics.

Version-Release number of selected component (if applicable):


How reproducible:
Feature does not exist.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-12-02 13:37:16 EST
REVIEW: http://review.gluster.org/6264 (cli: Add an option to fetch just incremental or cumulative I/0 information) posted (#4) for review on master by Dawit Alemu (dalemu@redhat.com)
Comment 2 Anand Avati 2013-12-03 21:09:42 EST
COMMIT: http://review.gluster.org/6264 committed in master by Anand Avati (avati@redhat.com) 
------
commit 133c370ec5e2688b6734acb087fe3769cb900a74
Author: Dawit Alemu <dalemu@redhat.com>
Date:   Thu Nov 14 12:52:14 2013 -0500

    cli: Add an option to fetch just incremental or cumulative I/0
    information
    
    'volume profile info' fetches both cumulative and incremental
    I/O statistics. There isn't a way to fetch just cumulative or
    incremental statistics.
    
    This change introduces two optional arguments, namely "incremental"
    and "cumulative", that can be tacked on to 'volume profile info'.
    In other words, the new command format is
    
    volume profile <VOLNAME> {start | info [incremental | cumulative]
    | stop} [nfs]
    
    'volume profile info incremental' - fetches incremental stats
    'volume profile info cumulative' - fetches cumulative stats
    'volume profile info' - fetches incremental and cumulative stats
    
    Change-Id: I5ddb45d990542ea611d23d251efebfec46f472d0
    BUG: 1030580
    Signed-off-by: Dawit Alemu <dalemu@redhat.com>
    Reviewed-on: http://review.gluster.org/6264
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
Comment 3 Anand Avati 2014-03-11 08:39:00 EDT
REVIEW: http://review.gluster.org/7217 (debug/io-stats:fix compile warning) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Anand Avati 2014-03-22 08:27:32 EDT
COMMIT: http://review.gluster.org/7217 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 16151032862af8ee70f14eff57162d829d8d75f9
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Mar 10 18:28:02 2014 +0530

    debug/io-stats:fix compile warning
    
    Compiler Warning:
    ---------------------------------------------------------
    io-stats.c: In function 'io_stats_dump':
    io-stats.c:950:24: warning: comparison between 'gf1_cli_stats_op' and
    'enum gf1_cli_info_op' [-Wenum-compare]
                     if (op == GF_CLI_INFO_ALL ||
    io-stats.c:951:24: warning: comparison between 'gf1_cli_stats_op' and
    'enum gf1_cli_info_op' [-Wenum-compare]
                         op == GF_CLI_INFO_CUMULATIVE)
                            ^
    ---------------------------------------------------------
    Fix: Use the appropriate enum in function defintion of io_stats_dump().
    Note: Using the same BZ ID as the commit that introduced this argument.
    
    Change-Id: I24e1aaf9ab86b4f337e3daa729d561ec208f2a95
    BUG: 1030580
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/7217
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 5 Niels de Vos 2014-09-22 08:32:45 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 6 Niels de Vos 2014-11-11 03:24:38 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users

Note You need to log in before you can comment on or make changes to this bug.