Bug 1030609 - katello 1.4 does not allow set_sync_plan on a RH product
katello 1.4 does not allow set_sync_plan on a RH product
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: 6.0
Assigned To: Christine Fouant
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 14:29 EST by Joshua Roys
Modified: 2014-09-18 11:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-17 14:35:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Roys 2013-11-14 14:29:54 EST
Description of problem:
katello -u jroys3 -p ... product set_plan --org $ORG --name 'Red Hat Enterprise Linux Server' --plan 'RHEL Sync'
User jroys3 is not allowed to access api/v1/products/set_sync_plan
IRC: <thomasmckay> roysjosh: we'll wait for bbuckingham to confirm, but i think a bugzilla is warranted. both set_sync_plan and remove_sync_plan should not be restricted to just custom products


Version-Release number of selected component (if applicable):
katello 1.4


How reproducible:
product set_plan on a RH product


Actual results:
failure


Expected results:
success
Comment 1 Bryan Kearney 2014-01-21 14:07:44 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 2 RHEL Product and Program Management 2014-01-21 14:18:30 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Bryan Kearney 2014-06-02 12:09:40 EDT
Can you please verify if this is still a bug. If so, fix it! If not, please move to ON_QA.
Comment 6 Christine Fouant 2014-06-03 10:45:16 EDT
[cfouant@centos-devel hammer-cli-katello]$ hammer product set-sync-plan --organization 'ACME_Corporation' --name 'Red Hat Enterprise Linux Server' --sync-plan-id 3
Synchronization plan assigned.

Note You need to log in before you can comment on or make changes to this bug.