Bug 1030624 - [abrt] gimp-2.8.8-3.fc20: g_malloc: Process /usr/bin/gimp-2.8 was killed by signal 5 (SIGTRAP)
[abrt] gimp-2.8.8-3.fc20: g_malloc: Process /usr/bin/gimp-2.8 was killed by s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:35be47611c53991817c0634e0ca...
:
: 1048498 1049140 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 15:05 EST by Mikko Tiihonen
Modified: 2014-04-30 07:50 EDT (History)
13 users (show)

See Also:
Fixed In Version: kernel-3.13.3-201.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 07:50:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (55.34 KB, text/plain)
2013-11-14 15:05 EST, Mikko Tiihonen
no flags Details
File: cgroup (147 bytes, text/plain)
2013-11-14 15:05 EST, Mikko Tiihonen
no flags Details
File: core_backtrace (39.43 KB, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: dso_list (10.87 KB, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: environ (3.81 KB, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: limits (1.29 KB, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: maps (3.11 MB, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: open_fds (909 bytes, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: var_log_messages (724 bytes, text/plain)
2013-11-14 15:06 EST, Mikko Tiihonen
no flags Details
File: binary (5.81 MB, application/octet-stream)
2013-11-14 15:07 EST, Mikko Tiihonen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 712330 None None None Never
Linux Kernel 67651 None None None Never

  None (edit)
Description Mikko Tiihonen 2013-11-14 15:05:44 EST
Description of problem:
When I open my PNG image using
$ gimp pirkko1.png

pirkko1.png: PNG image data 10196 x 14024, 8-bit/color RGB, non-interlaced, 148M

Version-Release number of selected component:
gimp-2.8.8-3.fc20

Additional info:
reporter:       libreport-2.1.9
backtrace_rating: 4
cmdline:        gimp pirkko2.png
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.0-1.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_malloc at gmem.c:109
 #3 tile_alloc at tile.c:163
 #4 tile_lock at tile.c:95
 #5 tile_manager_get at tile-manager.c:309
 #6 pixel_region_configure at pixel-region.c:565
 #7 pixel_regions_configure at pixel-region.c:547
 #8 pixel_regions_process at pixel-region.c:381
 #9 gimp_channel_real_is_empty at gimpchannel.c:1213
 #10 select_actions_update at select-actions.c:156
 #11 gimp_ui_manager_real_update at gimpuimanager.c:391
Comment 1 Mikko Tiihonen 2013-11-14 15:05:54 EST
Created attachment 824128 [details]
File: backtrace
Comment 2 Mikko Tiihonen 2013-11-14 15:05:57 EST
Created attachment 824129 [details]
File: cgroup
Comment 3 Mikko Tiihonen 2013-11-14 15:06:00 EST
Created attachment 824130 [details]
File: core_backtrace
Comment 4 Mikko Tiihonen 2013-11-14 15:06:04 EST
Created attachment 824131 [details]
File: dso_list
Comment 5 Mikko Tiihonen 2013-11-14 15:06:07 EST
Created attachment 824132 [details]
File: environ
Comment 6 Mikko Tiihonen 2013-11-14 15:06:10 EST
Created attachment 824133 [details]
File: limits
Comment 7 Mikko Tiihonen 2013-11-14 15:06:33 EST
Created attachment 824134 [details]
File: maps
Comment 8 Mikko Tiihonen 2013-11-14 15:06:36 EST
Created attachment 824135 [details]
File: open_fds
Comment 9 Mikko Tiihonen 2013-11-14 15:06:40 EST
Created attachment 824136 [details]
File: proc_pid_status
Comment 10 Mikko Tiihonen 2013-11-14 15:06:43 EST
Created attachment 824137 [details]
File: var_log_messages
Comment 11 Mikko Tiihonen 2013-11-14 15:07:22 EST
Created attachment 824138 [details]
File: binary
Comment 12 Nils Philippsen 2013-11-15 11:19:50 EST
I think it's best if we handled this upstream: http://bugzilla.gnome.org/show_bug.cgi?id=712330
Comment 13 Duncan Grisby 2013-12-29 19:40:36 EST
For me at least, increasing the kernel's vm.max_map_count parameter fixes this issue. See https://bugzilla.gnome.org/show_bug.cgi?id=712330#c8
Comment 14 Paweł Sikora 2013-12-30 12:08:14 EST
Another user experienced a similar problem:

sometimes .nef->.jpeg export crashes.

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        /bin/gimp-2.8
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.6-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 15 Doug Enright 2014-01-05 12:46:55 EST
Another user experienced a similar problem:

Gimp crash during editing (rotation) of a photo.  Approximately 3 other photos were open at the same time.

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        gimp-2.8 /home/enright/Pictures/2014-01-04/IMG_4190.JPG
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.6-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            500
Comment 16 Cezary Zemis 2014-01-13 15:04:02 EST
Another user experienced a similar problem:

This happened while using Gausian blur, however after Fedora upgrade (from 17 to 20) and hardware hange (from Lenovo T500 to Toshiba Satellite P70-A) GIMP crashes frequently and almost randomly. 

reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        gimp-2.8
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.6-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1001
Comment 17 Eric 2014-01-15 23:19:15 EST
Confirmed, it is a 3.12 kernel issue, and increasing vm.max_map_count fixes the crash. Thank YOU!!! This issue has been killing me. Mr Grisby, you just saved my life.

For those who don't know how:

$ sudo sysctl -e vm.max_map_count=131060

To know how many maps are used:

$ wc -l /proc/$(pidof gimp)/maps.

68064 with the image I was trying to open tonight.

Another workaround proposed by a GIMP developer:

run:

$ MALLOC_MMAP_MAX_=0 gimp
Comment 18 col 2014-01-18 06:09:17 EST
Another user experienced a similar problem:

ran the 'lomo' plugin in gimp.

reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        gimp /tmp/DSC_0704.NEF_8CEX9W.ufraw
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.7-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 19 Nils Philippsen 2014-01-20 05:39:54 EST
*** Bug 1048498 has been marked as a duplicate of this bug. ***
Comment 20 Nils Philippsen 2014-01-20 05:40:14 EST
*** Bug 1049140 has been marked as a duplicate of this bug. ***
Comment 21 col 2014-01-20 15:23:10 EST
as root,

sysctl vm.max_map_count=16777216

fixed this for me. thanks people.
Comment 22 Björn "besser82" Esser 2014-01-24 06:57:49 EST
Another user experienced a similar problem:

I tried to add some text-layer.

reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        gimp-2.8 /home/besser82/Downloads/FOC-Antrag%20Bj%C3%B6rn%20Esser.pdf
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.8-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 23 Greg Mansfield 2014-01-26 09:08:07 EST
Another user experienced a similar problem:

Loading 130MB tiff file

reporter:       libreport-2.1.11
backtrace_rating: 4
cmdline:        gimp-2.8
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.8-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1209
Comment 24 Cezary Zemis 2014-02-09 12:15:27 EST
Another user experienced a similar problem:

Pasting clibboard (rather large, cca 6500x4800px) to a new image.

reporter:       libreport-2.1.12
backtrace_rating: 4
cmdline:        /usr/bin/gimp-2.8
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.9-301.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1001
Comment 25 Benjamin.Wolsing 2014-02-15 06:43:12 EST
Another user experienced a similar problem:

Working with pictures

reporter:       libreport-2.1.12
backtrace_rating: 4
crash_function: g_malloc
executable:     /usr/bin/gimp-2.8
kernel:         3.12.10-300.fc20.x86_64
package:        gimp-2.8.10-4.fc20
reason:         gimp-2.8 killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 26 Eric 2014-02-20 22:00:07 EST
$ uname -r
3.13.3-201.fc20.x86_64

Seems to be fixed \o/
Comment 27 Mikko Tiihonen 2014-04-28 01:43:21 EDT
As the original reporter of the bug I can confirm that recent kernels have been fixed and this bug can be closed.
Comment 28 Nils Philippsen 2014-04-30 07:50:46 EDT
Closing as per comment #27.

Note You need to log in before you can comment on or make changes to this bug.