Bug 1030648 - node-web-proxy crashes on closed backend connection
node-web-proxy crashes on closed backend connection
Status: CLOSED DUPLICATE of bug 1034077
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On: 1034077 1034135
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 16:02 EST by Andy Grimm
Modified: 2016-11-07 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-25 12:10:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2013-11-14 16:02:31 EST
Description of problem:

Several of our nodes have seen frequent node-web-proxy crash/restarts with the following traceback (or something similar. WebSocket.send line 175 is always the location of the exception):

/usr/lib/node_modules/ws/lib/WebSocket.js:175
    else throw new Error('not opened');
               ^
Error: not opened
    at WebSocket.send (/usr/lib/node_modules/ws/lib/WebSocket.js:175:16)
    at WebSocket.<anonymous> (/usr/lib/node_modules/openshift-node-web-proxy/lib/proxy/ProxyServer.js:510:14)
    at WebSocket.EventEmitter.emit (events.js:98:17)
    at Receiver.self._receiver.ontext (/usr/lib/node_modules/ws/lib/WebSocket.js:550:10)
    at Receiver.opcodes.1.finish (/usr/lib/node_modules/ws/lib/Receiver.js:397:14)
    at Receiver.expectHandler (/usr/lib/node_modules/ws/lib/Receiver.js:378:33)
    at Receiver.add (/usr/lib/node_modules/ws/lib/Receiver.js:93:24)
    at CleartextStream.firstHandler (/usr/lib/node_modules/ws/lib/WebSocket.js:530:22)
    at CleartextStream.EventEmitter.emit (events.js:95:17)
    at CleartextStream.<anonymous> (_stream_readable.js:720:14)
DEBUG: Program node /usr/lib/node_modules/openshift-node-web-proxy/bin/web-proxy.js --config /etc/openshift/web-proxy-config.json exited with code 8

This error seems to be because the connection to the backend server has been closed unexpectedly.

Version-Release number of selected component (if applicable):

openshift-origin-node-proxy-1.16.1-1.el6oso.noarch
Comment 2 Meng Bo 2013-11-25 04:35:34 EST
Still meets such error on devenv_4067.

/usr/lib/node_modules/ws/lib/WebSocket.js:175
    else throw new Error('not opened');
Comment 3 Mrunal Patel 2013-11-25 12:10:34 EST

*** This bug has been marked as a duplicate of bug 1034077 ***

Note You need to log in before you can comment on or make changes to this bug.