Bug 103065 - numpad keys duplicate other keys, rendering them superfluous.
numpad keys duplicate other keys, rendering them superfluous.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-26 07:14 EDT by Stefan Linnemann
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-26 21:03:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Linnemann 2003-08-26 07:14:59 EDT
Description of problem:
In older versions, the numerical pad (numpad) keys of the keyboard used to
function seperately from the numerical and extra function keys.  Now their
functionality is a complete copy of keyboard keys elsewhere (number keys/arrow
keys/the six special keys(insert, home, pageup, etc.).  I've tried to reassign
the numpad keys to become function keys not elsewhere found on the keyboard,
but it either doens't happen or the assigned key produces no keystring.  So
either I make the change on the wrong level, or more work needs be done.  How
can I get both my linux console and the KDE/Gnome terminals to recognise numpad
keys with distinct functionality?

Version-Release number of selected component (if applicable):
Redhat 8.0, kernel 2.4.20-20.9

How reproducible:
On any terminal, use the Up arrow key and the numpad 8 (in non-numlock mode). 
They functionality is identical.  Same for all the other special keys and their
numpad counterpart.  In nuplock mode, the number keys on the numpad produce the
identical number from their numerical counterpart, the numbers 0-9, and the
symbols /*-+.  This is probably desired functionality for some, but extremely
undesirable for me.

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:
I expect my numpad keys to be seperately configurable from their counterparts on
the rest of the keyboard, but can't seem to find the right set of changes to make. 

Additional info:
Comment 1 Eido Inoue 2004-02-26 21:03:57 EST
the keypad does generate different codes for most keyboards
(demonstratable with the "showkey" command in the console).

As this report is not a bug, but rather a support question, I'm
closing it.

Note You need to log in before you can comment on or make changes to this bug.