Bug 1030667 - RFE: Have a way for a recovery alert to clear the prior alert(s)
RFE: Have a way for a recovery alert to clear the prior alert(s)
Status: CLOSED DUPLICATE of bug 1003211
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
4.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 16:53 EST by Elias Ross
Modified: 2014-11-04 05:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-04 05:12:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elias Ross 2013-11-14 16:53:51 EST
Description of problem:

Recovery alerts actually create an additional alert, plus they don't clear the old alert.

I created a custom alert sender that basically acknowledges the recovery alert with a fixed subject. I'm thinking of an addition to clean up the old alert(s) as well.

This is a placeholder for the feature I'm going to contribute.
Comment 1 Michael Burman 2013-11-14 18:59:21 EST
Elias, my patch to the issue 1003211 solves the same issue (it marks the previous alert recovered + adds filtering options).
Comment 2 Elias Ross 2013-11-14 20:01:34 EST
Michael, 

Bug 1003211 -- Looking at the patch, yours is a better fix, though I'm kind of happy with my plugin since it doesn't require having to upgrade my server or schema, and it's fairly simple (like 100 lines of code.)
Comment 3 Michael Burman 2014-11-04 05:12:08 EST
Closed because of merging of BZ 1003211.

*** This bug has been marked as a duplicate of bug 1003211 ***

Note You need to log in before you can comment on or make changes to this bug.